0 Devices Loaded

I’m trying to download Minecraft XBOX 360 maps but it shows 0 Devices Found when I plug in my USB. I’ve tried a bunch of things but nothing is working. Here are the steps I took:

  • Plugged USB into XBox > Formatted
  • Profiles > Move Profile > To USB Device
  • Downloaded and updated Horizon
  • Run as Administrator
  • USB plugged in.
  • 0 Devices Loaded - Clicked on that tab and gives message about if you do not see devices run as administrator.
  • Right clicked on Horizon > Compatibility > Checked Run as Administrator
  • Tried everything again.
  • Tried on a different laptop

Is there something I am missing? Need help. Thanks in advance for any help.

Try Downloading Horizon from here :https://www.horizonmb.com/client/v2/latest.php

There was a recent Xbox 360 dashboard update, have you updated yet? If you haven’t that’s the problem. Horizon will only recognize storage devices configured for the newest dash update.

Steve can u give the link? When i install newest updates its wont open Horizon?

https://www.horizonmb.com/client/v2/latest.php