All of a sudden Horizon stopped working

I was trying to open horizon after i used it many times and it says it has stopped working. The horizon startup icon (HORIZON) wont even show up. I tried using the .net framework clean up tool and reinstalling the framework but it gives me the same result.Then I tried to uninstall Horizon then reinstall=same result.Finally I tried using another mod tool and it worked perfectly. I am using windows 7 service pack 1 and x64 operating system. Any suggestions?

Uninstall Horizon, search this from the start menu %localappdata%, open the Local folder and delete the Daring_Development_Inc, then download from here.

Post back if you have more problems !

same result

Make sure you have .Net Framework 3.5.

Download from this link:

same result other mod tools still working.

I already had .net framework 3.5 service pack 1 but when I attempt to uninstall it says to turn windows features on or off. When I try to turn on or off Microsoft .NET Framework 3.5 in windows features it says “An error has occurred. Not all features were sucessfully changed.” I also attempted to use the dotnetfx_cleanup_tool.I also tried the .Net Framework Repair Tool.

If you want I could see if I could fix the problem hands on through Teamviewer.

sure maybe sometime this weekend

Okay, just remember to Private Message me the ID and Password.