Anno 1800 Cheats and Trainer for Ubisoft

This is the official discussion topic of the Anno 1800 Trainer and Cheats.


The Anno 1800 cheats have been updated!


  • Released trainer with 5 cheats

Please post in this topic if you run into any issues!


Hey, the cheat for influence is broken. instead of goof influence i get -64.000 :smiley:

The Anno 1800 cheats have been updated!


  • Bug fixes and game compatibility improvements

Please post in this topic if you run into any issues!

Sorry for saying. But the trainer is not working at all. When i push play when the game is off, the game starts after a little time and than i get an error in the trainer. When i run the game first and than try to push play i get an error also saying "we’re having trouble starting or finding your opened game. I didn’t have this at all with your old trainers. Maybe i do something wrong, but i can’t find any know how.

1 Like

What error message are you receiving when you launch the game Via the play button in WeMod?

“we’re having trouble starting or finding your opened game” and a retry button. So same error.

My apologies, I missed that when I first read it. You are using a uplay copy of the game correct?

yes, indeed

Please follow these instructions to select a custom install and see if it will start properly

Works great, thanks to the author

1 Like

Great mod, thanks for all the hard work. I ran into the issue that once you zoom in on the map you cant fully zoom out again, Is there a work around or a fix for this? Even after i close the game and re load it still keeps the closer zoom view not allowing you to full zoom out again.


Did try this. Also when wemod says that it is compatible with my version. I do miss the normal activation (working activation) of the old trainers. Even so i still use an older one. Only the inf. health ship option is not working.

So i see that tere is a big problem with the wemod app, it is searching the wrong way for the game.exe

There are two trainers one for Steam and one for Uplay

i know, i use the uplay, because i have a uplay anno version…

I have a problem, today, 14th August 2019, cheats no. 1 and 7 ( ship health/ strorage resources) are not working at all. when I click to turn them on, they automaticly turn off again. I think this is due to the last update.
thank you for the atention;

Which one are you using you posted in both uplay version and steam version ?
What version do you have ?
You said you are using the 10 cheat trainer in other post ?

You are using the trainer from stingerr ? Use one of mr.antifuns trainer till he can update his

Maybe try to open it via wemod program on PC, not download trainer directly ;p
works for me in the way above.


Trainer +10 on Uplay.
Since the latest update of Anno 1800 Ship Health (NumPad 1) and Storage (NumPad 7) no longer work.

Mrfun Ship Health and Storage also don’t Work.

Thank you in advance,

Hi MrAntiFun!

I believe adding “Perfect Needs Satisfaction” and “Electricity needs for World Fair/other buildings” would improve the trainer a lot better!