App Horizon

Assassin's Creed Odyssey Cheats and Trainer for Uplay

I start my game with we mod play button, game is in the menu. and then suddelny crashes.
I downloaded new game update yesterday but game version is still the same.

I have over 200 hours on the game and the trainer works quite well except in one instance: the so called “boss fights” will not let me proceed but become “stuck” right before the fight is initiated. For example, in They Only Want Cruelty, I can select and opponent and am transported to the arena but it is unpopulated and nothing further happens. This also happens with the Petrified Forest quest - all goes well until right before I am to fight the opponent, at which point it freezes and cannot engage in the fight. When playing the Pirate Hospitality > Island of Misfortune it displays “Pay Xenia Drachmae” even though I did pay Xenia during the quest. However, when I did so, she fell dead. So it appears that during these major challenge quests, the game simply refuses to process the quest action.

Hope this is clear and that you can offer assistance.


Seems Invisibility is not working after the 1.10 update. I have it set but I’m detected. Anyone else experiencing this?

@pilg4704: Map markers don’t always point to a PERSON. The marker is an invisible canvas most of the times set over an object (like a person); at times it’s not like that, depending how the game design was conceived. That’s why sometimes it works, sometimes it doesn’t. With what you describe… boss fights… there usually is a CINEMATIC before the actual stage begins. So that marker points to the cinematic entry point; the boss is spawned thereafter. If map marker is over a building and you have to go inside the building to trigger a cinematic, then there’s no point using map teleport T_T. For most of the “quirky” situations you’ve faced, you’ll have to think: why doesn’t it work? The answer is pretty obvious: you people expect the trainer to work like I were the game’s developer; not the reality. Furthermore, if you use invisibility, you won’t trigger opponents to attack (check that you’ve not enabled invisibility at the same time with some other option; check your hotkeys so they don’t overlap: Ctrl+Alt+F will also do Ctrl+F if you have them set-up like that; no idea if Frank fixed that). Can’t offer any assistance but use the freecam; the Shift key to speed up movement adds like 1-2 seconds as opposed to map teleporting. So use that instead and don’t complain.

@GamerDad050862: Will check.

1 Like

Not sure I described the issue clearly: In each instance of a “boss fight”, I am transported to the appropriate location (i.e. the arena floor or the Minotaur’s cave) but only my character shows, no cinematic starts and no opponent appears. The game simply continues to display the “arena” but there is no way to continue as the cinematic does not play and no opponent appears…this occurs with the Petrified Forest, Minotaur and the other major “boss fights”. So far, I have reloaded the last playable save and skipped the “boss fight” to continue to play. I have tried, loading the game without the trainer but the same thing occurs. If you have any suggestions, I would appreciate your help. Congratulations on a great trainer that functions perfectly except for this one hangup…

Do you understand what the word trigger means? If you teleport in mid-arena, the engine, which loads decals as you move on a span of 100m around you, will not load what’s supposed to load when you skip hitting the trigger spot at given XYZ (don’t ask me where it is; don’t really care). As I said… put marker someplace close (NOT ON IT) and teleport BEFORE the arena. Then enter normally. I’ve provided an alternative, using freecam. Don’t want to and want it your way, figure it out then :stuck_out_tongue:

^ That’s the general explanation.

Now… considering you’ve tried what you’re describing without anything on… I wouldn’t be able to tell what exactly in your save is triggering your problem. It clearly isn’t a trainer option. But… if you’ve used some stuff that broke your save game somehow (e.g.: the all-known inventory editor; which you probably did to get items you didn’t want to buy[?]), then that might be one reason some stuff on your character or your inventory causes these mishaps. If none of this, then report the bug and see if Ubi can help with your save. All I can recommend.

1 Like

There is an issue with the resource picker. When I go to add Ancient tablets, it does not let me add them to the game. Every other resource works fine. Hopefully you can get it resolved soon, thanks.

This is where I’ll tell you to go read post #2 :slight_smile: Note 10. Thanks!

Hey folks! Unfortunately Ubisoft has left a lot of content behind a paywall. Will it be possible to optain Orichalcum Ore using the trainer? Will such a function be added? Cuz thats the only way to obtain precious ingame-shop-items without spending helix credits/real money.

Also…I haven’t started playing the game yet and I’d like to know if there are any trouble with the trainer if you own the game on uplay. Thx for sparing the time to make this trainer happen!
have a good one :)!

Orichalcum is server side and cannot be edited with a trainer.


but thx for the reply

hi it seem like the cheat engine isn’t working. none of the cheats seem to work

Hi! I got the game on uplay and just tried using it by simply telling the wemod client the aco.exe in my uplay folder is a steam version of the game. this doesnt work cuz i cant use any of the options properly. will there be a uplay-version or am i doing something wrong? i couldnt find a request for a uplay-version

There is and it works for uplay version. Need to read the first or second comment in this thread from sunbeam on how to get it to work !!

Hey man! Thanks for replying so quickly. I might just be incredibly retarded but I really couldn’t find the post you spoke of within the first bunch of posts on this forum. Could u perhaps quote it here or explain to me what I am doing wrong? When I got WeMod there is no uplay version of the cheat but i guided the steam version to my acodyssey.exe . this doesn’t work though

also: it says the trainer is for version 1.10 but i got 1.07 even though i got it on uplay meaning i should have the most current version cuz i bought directly from the devs

You need to select the UPLAY version of the cheats.

1 Like

Great Trainer @SunBeam. your work is awesome. Trainer works perfectly

1 Like

For me it says there aren’t any trainers available for the uplay version. However using the steam version works well most of the time now :slight_smile:

1 Like

Could you implement the option to cheat that special currency you can only use in one store??

Can you ask a question without using double question marks???

1 Like