Asus RT AC66R slowing upload speeds

I’ve had this router for months now and for some unknown reason today it decided to kill my upload speed. I pay for 100, 10 and my download is fine, but my upload is peaking at .40 or less. I’ve updated all the firmware for the router, but I’m completely stumped. I’ve done a speedtest connected directly to the modem and it gave me the speeds I pay for. I’ve also turned on QoS and set the up to 40. Also I tried my old $60 netgear router and got the same results. I have no idea what could be causing my upload to be so low.

Well, these are a few things I was going to suggest prior to reading the paragraph:

  • Restart your Router.
  • May seem like a very simple problem solver, but can sometimes actually fix dumb network issues.
  • Update the Firmware.
  • A very obvious solution that could be the issue, but you’ve already claimed to have done this.
  • Change “QoS” Settings.
  • Contact your ISP.
  • Isn’t something that a lot of people want to do since customer support is so great, but it could solve your issue. (ex: See if there are any outages within your area that could be causing your internet to not be what it’s supposed to be.)

Taking what you said into consideration and thinking beyond those few suggestions, I’d guess your internet is being throttled. Granted, it’s the beginning of the month rather than the end, but depending on what you do with your internet and who you have as a provider I wouldn’t know what else could be the issue.

Best of luck and sorry I couldn’t provide a direct fix!

P.S.
My buddy had a similar issue awhile back where he tested his connection via SpeedTest, would get the speeds in which he paid for, but would still have issues when on his console(s) and such.

You do realize that bytes and bits are completely different metrics right?

Also if you aren’t using said metrics in your OP, I don’t see how we are suppose to understand your issue properly.

Also, I know with a lot of ISP’s just because you pay from something doesn’t mean you are guaranteed to get it.

EDIT: Since you’re getting the proper speeds when wired, it could also be the device you’re on… Have you tried a smart phone speed test or another laptop?

Yes, they have a range that you may be win, AKA a minimum speed.

Just call up and start complaining about it, that’s what my Dad did and we ended up getting the best plan they had.

I’d be surprised if that gets you anywhere considering I can guarantee it’s your network doing it. People overestimate how many times their ISP is the root cause of their internet problems.
As far as a solution, it’s really hard to say without being able to see the network myself.

I would try power cycling your modem/router first before calling them.

Supposed to be 100 megabit(so 10 megabytes) and 10 megabit(1 megabytes upload). Regardless I’m not getting the upload speed I’ve gotten for almost the past year.

I’ve tried running multiple speedtest sites and multiple devices as well. I’ve tried everything sniapzor and autrix have said to try. I contacted comcast support, online support couldn’t do much so they’re forwarding a ticket.

If the speedtests are saying you are getting the correct download speed, but your aren’t in reality, are you sure you don’t have a worm that is messing up your upload speeds? Or ad-ware?

I’m not getting the UPLOAD I’m supposed to be getting. Download fluctuates with speedtests, but 75% of the time it’s around what I should be getting. Speedtest is saying I have garbage upload and I had packetloss on league, twitch streams were pausing an absurd amount of the time, and pages were just taking longer to load. None of this happened 2 days ago. Pretty sure I don’t have either adware or a worm since this problem started yesterday and I hadn’t anything to receive either of those as of recently.

And you have tried refreshing your router/using a different router? And are positive it isn’t on their side?

I said I tried another router and still had the same issue and I also said that I contacted support. Support determined there was something wrong with the connection that simply restarting the devices wouldn’t work. They forwarded my ticket to their technician team so now it’s just a waiting game.

Support is usually full of idiots.

Call them up and ask them to refresh your connection.

99% sure it will work.

lol thats what the guy did. He refreshed it, had me power cycle and refreshed it again.

I apologize on behalf of not being able to help you, but, like others have already stated, I’d assume the problem is on Comcast’s end and they’ll resolve the issue in time.

Best of luck!

Then there is nothing more we can do for you tbh.

Literally did nothing and all my speeds went back to normal.