Avatar awards corrupted


I’m having a problem with some avatar awards I want to unlock. The games in question are Deadliest Warrior1, and Forza Motorsport 42.

I am on a RGH console, never signed in to XBOX Live (for some reason its wireless adapter shuts off as soon as the dashboard boots), and I therefore cannot download these award items through XBOX Live.

I have Velocity, which in addition to its Avatar Awards unlocker, brings the option to download these award items. When I inject them into a flash drive with Horizon, they show up as corrupted in System Storage, and as a “!” sign in the Avatar editor.

Any help please? :cry:

Thank you very much in advance!

1 = In the case of Deadliest Warrior, I have tried to unlock these awards manually, but they still don’t work.
2 = Forza Motorsport 4 has an award that can manually be unlocked only through XBOX Live.

when u put your hard drive in do u save it to your flash drive like u would for gamerpacks?

So you’re using two different modding tools to unlock avatar awards and then wonder why everything gets ****ed up? I would recommend using only one tool, not two.

He owns a rgh, so i’m guessing he knows how to use a flash drive.

I have got that part worked out. I’ve managed to unlock and download the avatar awards smoothly. I have a different problem now (I have a problem with the awards of a certain game - Deadliest Warrior) which exceeds this thread, so I’ll have to make another one.