Battlefield 4 Cheats and Trainer for Origin

Battlefield 4
This is the official discussion topic of the Battlefield 4 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. God Mode
2. Unlimited Ammo
3. No Reload
4. Unlock All Weapons
5. Unlimited  Health Vehicle
6. Better Accuracy
7. No Recoil
8. Super Speed
9. Bullet Time


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 07/25/2019
    Started development

  • 07/25/2019
    Released trainer with 13 cheats

  • 07/27/2020
    God Mode cheat added
    Unlimited Health Vehicle cheat added
    Better Accuracy cheat added
    Super Speed cheat added
    Bullet Time cheat added



Like what you see?

Check out all of the games WeMod supports here.

The Battlefield 4 cheats have been updated!

Changes:

  • Released trainer with 9 cheats



Please post in this topic if you run into any issues!

Bought Battlefield 4 on steam (it was on sale, Had the same issue with V and 1) WeMod can’t find the game, When I link it, It’s not supported, So the trainer doesn’t activate, The only trainer for the latest version of the game is from 2017. Games are installed to an External Hard-drive and WeMod detects them fine, It’s just the battlefields, It doesn’t want to find. (And this is for Single-Player mode only, I F*cking hate multiplayer)

Hey @TheArachne. :slight_smile:

As the name of this trainer suggests, it was built specifically for the Origin launcher version of the game. A Steam version may need a separate trainer due to slight differences in the game engine code of different store versions of the same game. A Steam trainer can be requested via the WeMod desktop app. :slight_smile:

Hey MrAntiFun couple days ago the trainer was wroking fine. but today the trainer is not working in game! can you fix it. thank you so much

Hello, i launch battlefield with wemod and your trainer.
I activate unlimited ammo, no reload, unlimited health.
When i kill ennemies, they stayed up like statues.
Sometimes the rifle won’t shoot.

I restart the game with wemod and your trainer, tried to play with nothing activate, same problems
Then, i fall under the map…

I have Origin latest version with BF4.
Everything works when i launch the game without your trainer.

Thanks if you can help me.

Welcome to the community @Panammmm94. :slight_smile:

Your issues sound like they are issues with your copy of the game (ie - it’s corrupted or cracked) or your PC (ie - it doesn’t meet the minimum specs to run the game correctly).

The biggest clue here is the falling through the map. There’s no technical reason why a trainer would trigger that because trainers do not touch the game in any way. They just inject values into your PC’s RAM.

  • If your game is cracked, we do not support your copy.
  • In case your game is corrupt - verify the files via Uplay Origin Launcher.
  • If your PC doesn’t meet the specs to run the game correctly - stop playing the game. You’re only causing internal damage to your machine.
  • If you are attempting to use the trainer on an online game mode - don’t.
  • If your antivirus is blocking WeMod - add it as an exception.

Hi,

My game is totaly legal, bought on origin.
Don’t undestand why you talk about “Uplay Launcher” for an origin EA games.
My computeur allowed me to play in ULTRA without wemod activated. (i play COD Warzone in ultra).
I only try it on campaign solo mod, not on online.
Don’t think my antivirus is blocking wemod because i already played BF3, FarCry, COD… with wemod and no problems appears.

Thanks for your help

(Sorry for my english i’m french)

Thanks for pointing that out. Those instructions were copied/pasted from another post for a different game. Just swap the word “Uplay” for “Origin”. :slight_smile:
Usually, you right-click the game in the launcher’s library, then click “verify” or “repair”.

This doesn’t mean anything. Antiviruses can be fine with some trainers but not with others.

Hey guys.
I´ve been having this error for quit a while now.
When I launch wemod and click the BF4 trainer, I get the 9 options as referred on the trainer.
As soon as I add the BF4 instalation file, the trainer shifts to 13 options and it stops working in-game.
I’ll attach a print screen of both before and after I add the .exe file location of BF4.
Hope I was clear enough!
trainer_before_exe_file|589x500


Trainer with 13 options after I add file location

Go into history under the play button and click on the trainer you want to use.

Hello… I have been trying to use this trainer; but every time I start it it closes the game and I get an error that I am running a 32-bit version of the game. I have unistalled and reinstalled the game multiple times and the same thing still happens. Any help on how to fix this would be greatly appreciated.

Hello there. :slight_smile:

If you copy and paste the entire error message that WeMod gives you into the forum’s search tool, in general you’d find an answer very quickly.

Here we go: "These cheats were made for the 64-bit version of the game, you are running the 32-bit version" - #2 by Ravenfyre.

Thanks for the reply. I followed the directions to start the game and now I receive the error on the screen shot. Please note that this is only happening with Battlefield 4; all my other games work fine.

I can see in your screenshot that you are using a very old trainer made by “Unknown_v2”, who is retired from WeMod. Therefore that trainer is likely very out of date.

You should be using MrAntiFun’s trainer if you have the game from Origin.

@Ravenfyre, Thank you for your help. I now have another issue. I have tried playing the game by loading through Origin first and through WeMod; both times the game starts and on the home screen I go back into WeMod to pick my options and WeMod says it can not find the game; even though it is open and running… see attached screenshot

1 Like

Could you try adding WeMod as an exception in your antivirus program? Specifically the three files mentioned at the bottom of this post: Windows Defender marked WeMod as a Trojan - #2 by Ravenfyre (you can ignore the rest of the text there).
And where did you get the game from?

Thank you :slight_smile:

Hey I have a problem with the weapon unlocking. I don’t know what that means"Unlock weapons in creates". Can I get a little help?

currently does not work, vercion 2021