Borderlands 2 game save corrupt

Hi Guys,

Just joined today so excuse asking for help straight away. My xbox froze last night and i lost my level 38 commando save due to a corrupt file. Is there any hope of repairing the save file to what it was originally using Horizon.

Never used Horizon etc and not sure where to start so thought i’d ask some advice first.

Did you use any mod tools before it froze or did you just play and suddenly it froze?

None at all mate, have never used any mod tools. The game was saving at one point then froze, had to reboot then when i got back onto the main screen it said your profile data is corrupt you will have to start a new game.

Then im not sure to do then :expressionless: Sorry

Post a link to your save file on mediafire and I’ll take a look at it. Not sure if I can fix it, but am willing to give it a shot.

Much appreciated, link below thanks for looking at it:


I’m taking a look at this as well , I’ll post the save back after I’m done .

Thanks guys, i appreciate your time on it.

I rehashed and resigned it and switched to the id’s to one of my profiles and it worked . So , I switched the id’s back to your profile , ect . Should work now ; Save0001.sav

Superb mate thanks very much, i take it i just drop it back onto my memory stick and go back on xbox with it. Having read the sticky about modding will microsoft take action for this or is only for more serious things?

Since you did not actually mod anything in the game you will be just fine :smile:

They won’t do nothing for something like this . And put it back on the flashdrive or hardrive .

Thanks for all your help, greatly appreciated.

Hey guys, I also had the problem with my save being corrupt. I just signed up to the forum to ask for help but when I went to copy my save from my Xbox hard drive to a USB I don’t have an option to copy, I can only delete. Would appreciate any help. :smile:

Did you format the USB so you can use in on your Xbox?

Yes, I can copy everything else from the hard drive accept the corrupted file. :confused:

I don’t think they would care about something like this. Thanks to GnarlyOCMD for getting it fixed.

edit: was responding to armored hawk in my post .

Some saves you can only move and can’t copy. Have you tried just moving it to the usb?

I can’t move either, I can only delete. When I saw this thread I got super excited because I thought I could get my Commando back. :cry:

Just a stab here, but are you sure you are signed in on the right profile for that save?