Can't Download Infinity

So when I try to download Infinity after clicking on the installer a box will pop up telling me it’s downloading the required files. This will reach 100% and disappear and then nothing would happen. Can anyone help me?

I’m running 64bit Windows 10 and have tried turning off my antivirus and firewall but it doesn’t seem to work.

Um, thats strange. If you try search for it, you get nothing?


I’ve made a video demonstrating the problem:

Ya find out where you downloaded to like your desktop ?
Then click on infinity to open it

All I can find are the setup files but not any actual files.

Are you using any type of Antivirus? if so add infinity to exceptions and disable it. Make sure no Firewall is interfering aswell.
Start the setup as admin to be sure to have all permissions needed

I fail to see what the issue is. Infinity creates both a start menu shortcut and a desktop shortcut that you can launch it from. The installation location is %localappdata%/infinity.

1 Like

Odd, I’ve checked the local app data and have tried clicking on the application but nothing happens.

I think it may have to do with the squirrel setup itself as I have kind of the same problem with the Discord app on my PC. And they both use squirrel setup.

Copy and paste the Discord part of the setup log.
Maybe we will find the error in there

Hey there, got the same problem as Euan and fixed that part with reinstalling Discord as well… Now the problem is that the log tells me that Infinity can’t be installed cause:

C:\Users"user"\AppData\Local\Infinity\packages\Infinity-3.0.16-full.nupkg" gets the access denied.

I checked if I could change the settings of that part so it would work but “Infinity-3.0.16-full.nupkg” doesn’t even exist.

Had to reinstall cause a data for 64 bit games “went missing” and @frank told me to reinstall.
Any Ideas people? :x

Start the setup as an admin and be sure you’ve got all the permissions needed for the installation.

I’m the admin and only user of my pc am I not having “all” permissions there are? How do I check

Press right click and start as admin or something like that.
Being the only user on the computer does not always start programs/setups as admin.
Neither does it automatically mean you are an admin

I got the same problems but it doesn’t disappear it gives me a error

I got it to work it works for everything except farcry 5