Cant Launch

Hello, firstly love the help this community seems to give its users so hoping someone here can help me out.

Ill start by saying I have tried everything so far on all other topics relating to this issue;
VPN’s, Fresh Installs, Disable and Removing Anti-Virus, Clean Cache, Adding White-lists and Direct Downloads… everything and yet nothing seems to work, the app just hangs on the loading screen with the saying, “Your game, Your rules”

If anyone knows anything please reach out I would love some help.

Also to note I am not using any of the ISP’s from other threads saying they have issues with certain ISP’s

EDIT: I also tried everything on this thread

Hello and welcome to the WeMod community.

A minor issue with WeMod earlier was fixed very quickly by the awesome developer, Frank. Those pesky tech-eating gremlins get everywhere!
More details here: [Bug] WeMod Beta (v6.2.18-BETA.0) Locking Up.
Close WeMod via Task Manager and restart it. If you’re still having issues please let us know.

Have an awesome day otherwise! :slight_smile:

1 Like

Great stuff thanks heaps!