Can't open the install file

I’ve downloaded at least 5 of horizon install file , and any of them is working.
(Dont show any error message)

Installing a previous version, the Horizon cant ready any pendrive .
(I’ve already configured all of them, and all have games in it. And, yes, I’ve already run the exe file in administrator mode)
:confused: There’s a way to fix it ?
My OS : Windows 8 x64

maybe horzon doesn’t work with windows 8 and 8.1 .

my os is windows 8.1 it won’t instal :anguished: and says error code 2

Horizon runs fine on Win 8.1, guys, that’s what I have.

Try downloading from this link:

You may also need to unblock the setup files/installer. To do this, right click on the setup files/installer, open properties, look for the Unblock button near the bottom and click it, now click apply and then Ok.

I am having much the same problem. I clicked on the link above and it takes me to horizon homepage. I click the download now button and it takes me to a new page that tells me how to download the installer. i follow the directions, (Click download, create a shortcut, follow installer directions.) i create the short cut and try to open it but when i do i get this message: “There was an error starting the installer. Please try downloading the installer again.” i have .NET 3.5, I’ve disabled my anti virus to try this, I’ve tried running it as admin, and i tried to redo the entire process, but i keep getting the same message. i need help.

When you click that link this should pop up: [details=Open Me][/details]

Are you using Chrome? If you are, try using Internet Explorer or Firefox to download it from my link above.

When you’re successful with the download if the setup installer doesn’t seem to want to run try this, right click on it, go to properties, look for the Unblock button near the bottom and click it, now click Apply and then Ok. Now it should run and install properly.

See if those suggestions help and post back if you need more assistance. Good luck.

it did much the same thing. the link again took me to horizon home page. when i clicked download it brought up a small window on the bottom of the explorer that asked if i wanted to run the install. i clicked run and it failed the same way. the box you posted never appeared. if you could post the link again and offer more suggestions id be very appreciative.

I just uploaded the latest version to Mega for you.
Here’s the link:!zclwEBbS!NV_YiDeA3HvbCQIrHaFLlZfs886gECzQHEk1GOWPI2A

Try downloading from there and let me know how it goes.