Company of Heroes - Legacy Edition Cheats and Trainer for Steam

Got it working, just add the RelicCOH.exe from the …common\Company of Heroes Relaunch folder then run it from the trainer tiny play button that it creates under the “Big” Play button, the game should then run, but the trainer won’t give you that “duplicate …” error if done right but will say it can’t find game do not worry the game will run regardless, then when in the main menu alt+tab (if you use 1 monitor) just hit Wemod “small” Play button again and it should then goto PLAYING almost instantly (I activated cheats in main menu and it worked, haven’t tried tot turn them of and on manually yet) hope this solution works for you, yes it’ll show it’s running the Original game from the original folder, but it’s playing the legacy edition as that actually connects online and shows the steam workshop tab (if it doesn’t then you did it wrong) but the cheats will still work. Also on another note had to use this technique, when the game was on my SSD gaming drive, but when I moved the game to my HDD, the cheats work perfectly without having to set the game to the …Relaunch folder, so either odd behaviour from my PC, if anyone else can confirm this to, would be appreciated

i have company of heroes complete on steam comes with legacy edition and all dlc i believe
i start the game and activate my cheats says playing when im in game the cheats are not working even when its says they are on/active like they are not syncing in-game.
plz help fix

UPDATED INFO - Run the normal game from steam as it uses the proper version now legacy with the WORKSHOP active. Then use the previous manually made smaller play button as written in my description above, the cheat should function as usual in the correct game version with WORKSHOP active meaning yes it works in all expansions and skirmish MP Only Mods too, works like a charm

Yesterday i started playing COH after a while and i wanted to try WeMod for this game. So i had the same problems other players had too. But i realized that the vanilla version was not installed in steam. After fixing this i started the vanilla version and the trainer works fully with it and all dlcs.

Do so:

  • download the vanilla version for steam (if you already have the Legacy Edition you also need the vanilla version)
  • start the vanilla version on steam
  • open WeMod, choose Company of Heroes and press play (if WeMod can’t find the game fix it but it’s necessary to start the game first)

so is this version worked with the legacy edition? it seems the trainer don’t worked with the legacy edition

Hi Stingerr,
your cheats are great and working, but I would like to ask if you could make these working for Blitzkrieg modification?

I tried to use executable of Blitzkrieg launcher in wemod, but the game won’t start.

So… to use this, you need just Company of Heroes too? Not just only Company of Heroes - Legacy Edition?

Is it need all those DLCs too?

It still doesn’t work.

Unfortunately, the WeMod doesn’t work. I have steam and used CoH Legacy Edition.

Dose not work for legacy version tried to check nothing works unfortunately

the trainer needs an update it keeps saying outdated?


Please update the trainer!

If i run COH relaunch from steam the game is fine.(no cheats)
if i then try to use the > play button in wemod it says unknown game.

If i launch the same game from wemod it loads but i can’t play as it says there is no valid key. So all is greyed out.
And legacy edition does the same.

Need a Mod for version 2.602.

1 Like

Yeah, this mod does not work. It’s the very first mod I’ve gotten from WeMod that’s useless for me.


Please update, the cheats do not work.


The mods are out of date please update


please update

1 Like

The Company of Heroes - Legacy Edition cheats have been updated!


  • Bug fixes and game compatibility improvements
1 Like

why 4? they used to be 9 -_- :pensive: