Deus Ex: Mankind Divided Cheats and Trainer for Steam

So first I tried to just go full-on, be max level, upgrade everything and just treat it like a new game plus kinda thing. But the menu turned invisible, didn’t even work when I tried to go back to a previous save with everything turned off item menu was still invisible. Then when I try to use to have just unlimited energy same thing. I play for 10-15 minutes and the item menu turns invisible. Any idea what is doing it and how it can be fixed?

When I want to launch the trainer and my game is on, the trainer can’t connect to my game and fails… If anybody can help me… (sorry for my bad english…)

Unfortunately, this trainer does not work with Version 1.19 Build 801.0, all WeMod does is keep trying to loading the game even though the game is running. I have a feeling no updates are forthcoming.

Extensive details list; trainer SHOULD be updated accordingly:

Unlimited grenades;
doesn’t work ; no effect:

literally doesn’t work, grenades and mines both get used up regardless of it being enabled.


Unlimited gadgets;
Not as expected;

By gadgets, it should include everything in the crafting template, PLUS crafting components.


Unlimited energy;
Other;

when hacking a terminal / computer, your invisibility will fizzle out in the middle of attempting a hack; leading to near death situations.


Extra details that should be deemed useful:

Unlimited items also seems to be broken, the inventory can be filled with multiple black “blank” instances when moving items around and these blank instances cannot be interacted with: this can lead to inventory full errors and loss of Frames Per Second performance. I suggest the trainer is updated immediately.

1 Like

The Deus Ex: Mankind Divided cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements



Please post in this topic if you run into any issues!

Hello! I want to preface this by stating I do appreciate everything you all do!

Now onto the issue at hand; I’ve reinstalled this game from Steam already and ran the validate function. Both did not come back with any issues. I am running Windows10 for this game as well.

I attempted to click ‘Play’ however after the ‘Loading’ runs for a bit it comes back with ‘We’re having trouble running the cheats. You may have to allow WeMod through your firewall or anti-virus software.’

I’ve also already tried running this after disabling the anti-virus and firewall, same results. I also submitted feedback in-case it bundles some debug information with the submission. Please let me know if I can help at all to get this functional. Thanks!

1 Like

I’m having the same issue as @njtitans09 , game crashes after selecting “play” from Wemod. I tried launching the game first, then trying to load cheats, it just keeps trying to load. I tried older versions in the app as well, same effect.

Edit: After re-installation wemod will allow me to launch the game, but the cheats never load.

haven’t been able to try it out yet, I had the issue of items in menu turning invisible. But I’ve used Flingtrainer for another game which works so maybe their trainer will have less issue. He just put it up on a drive with all games from 2012-2019 so instead of having to search for it on his site you can get it here. https://onedrive.live.com/?authkey=!AIJVHgD_2ICo2Fo&id=A3003ABFCB542735!106&cid=A3003ABFCB542735

1 Like

Same problems as the user above, with the Steam version, WeMod just spins and spins with the “Loading” when you click Play.

Not sure if the issue is because when you click Play in WeMod it actually loads a launcher, then you have to click play, however, whether you do that or whether you launch the game and then click Play, WeMod continues to spin and never changes to “Playing”

If you then go back to “My Games” and where it says cheats are still running you click “End”, the next time you try and click play (while the game is running), it will spin and then say that I may have to allow WeMod through AV/firewall, but I don’t think that’s actually the issue as I’ve never had to for any other game.

Been using for ages, but now for some reason I’m getting the same issue as the guys above? Don’t know if the games updated and broken it, or if something else is going on. But the cheats are now completely unusable.

Same issue as above, would probably need an update to accommodate the launcher @STiNGERR (just tagging for vis, not urgent :slight_smile: )