Deus Ex: Mankind Divided Cheats and Trainer for Steam

Ok, thank you.

the game completely bugs out whenever i use these cheats, im talking loading times for dialogue, looting icons in the raidal menu not showing up and crashing. is there a fix?

1 Like

Welcome to the community @LovelyTiger16.

To be honest with you, your issues sound like they’re hardware-related.
Trainers do not touch the game in any way at all. Trainers work by injecting values into memory addresses in your PC’s RAM. This generally doesn’t lead to lag or visual glitches in the game.

Make sure your GPU is up to date. And that you meet the minimum specs to run the game (ie - have enough RAM to run both the game and WeMod).
The last time I experienced similar issues in another game was because my computer didn’t quite meet the minimum specs to run it. :slight_smile:

i have 16 gb of ram and the game was at medium, tried it without cheats and ran perfect, turned on we mod scripts and it fell apart. the game was only using about 9 or 10 gb in the hub area, so i promise it wasnt ram

Hello and thank you for the reply.

Unfortunately it is still likely to be an issue that is not on WeMod’s end. Simply because trainers do not interact with the game in any way at all. It doesn’t make sense for a trainer to be causing increased load times or graphical glitches - it simply does not interact with any of these areas of the game.
I have read previous posts in this thread and nobody else has reported this issue. This is the sort of thing that would cause dozens of reports.

Where did you get your copy of the game from? Legitimately purchased from Steam or another store? Or cracked/pirated? We’re not here to judge you, but the latter would have compatibility issues with third party software, such as trainers and community mods.
If you have the game legitimately from Steam, try to verify the integrity of the game files:

Nah, I bought it on steam for 9 dollars when it went on sale. Beat the tutorial, went back and did it again with we mod. It seemed to work, but after the tutorial everything bugged out. Tried it without we mod, worked like a charm. Verified files twice, re installed once. Didn’t do anything. To be fair, I only measured ram usage when I wasn’t using we mod, but surely we mod wouldn’t use more than 2 gb of ram

I’m having the same issue. Clean install of win10, updated, latest drivers. These issues don’t occur on my Linux box or in win10 when I play without WeMod. With WeMod, especially with the unlimited gadgets cheat enabled, the UI can get glitchy and doesn’t always load in or is very slow: missing hud elements when you mod your gun, missing item icons, dialog wheel takes a while to appear, etc

I switched to using DX12 in the launcher settings and these issues seems to have resolved mostly, but then textures seem to break sometimes (likely unrelated to WeMod since DXMD states DX12 is ‘unstable’).

It’s certainly not a hardware issue as I’ve only experienced it with DXMD, specifically the steam version, and frequently while using WeMod.

1 Like

Maybe you should update the trainer then. The infinite items cheat is completely non-functional; it’s supposed to keep your items maxed out: when I first tried infinite items, you would get 99 custom parts whenever you sold 1 part to any merchant; now it doesn’t do that any more. I stand by what lovely tiger said; mankind divided’s trainer is in need of a serious update, if not overhaul.

we need a update

1 Like

100 percent in agreement, I am currently hoarding yellow tokens to exchange in bulk for pink tokens in request for an update to this trainer, my goal is to reach 30,000 yellow tokens, in order to buy in bulk at least 3 times over.


Hey @Kuwi_The_Messenger. :slight_smile:

Thanks for being Pro, first of all. We appreciate it a lot.

Don’t forget that you have a referral link in your WeMod dashboard which you can use to invite friends and people from other communities (ie, social media, Reddit, Steam, Discord,etc) to vote too, while being rewarded for it. :slight_smile:

Handy link: How do I find my referral link? - WeMod Support

Have you found a way to fix it? My UI doesn’t just get glitchy it refuses to load at all after using the trainer for more than a few minutes and I really am just interested being able to play the game without having to worry about energy.

And it’s nice to see a member of staff be so honorable, respectable, and humble.
Do you mind if I DM you a request to add in a cheat to an existing trainer? I imagine the staff have got the code for the wemod app on them nearly at all times.

Actually as old as the game is 2016 probably won’t be any cheats added to this. Sorry about that. Maybe if the game has an update and we have to come back to it and see if its possible to add something

I was referring to another game, which is why I want ravenfyre to DM me.

It is best to make suggestions in the official thread for that trainer, so that the trainer developer themselves can see it. I am not a trainer developer. Suggestions are appreciated because they help to improve things. :slight_smile:

well three suggestions I have for this trainer are:

  1. Adding a “violence enabler”
    A violence enabler, as the name implies, is a cheat that unrestricts the players guns, augmentations, special moves, etc. in an enviroment that directly disables them such as the helipad or secret underground base.
  2. An complete overhaul with the state of the trainer, it’s kinda fallen into disrepair. Laggy inputs need to be fixed, invisible items in the inventory, items overwriting each other even when dropped; it’s frankly a mess.
  3. Ammunition changer which branches off into several types:
  • EMP, Flashbang, Frag, Rocket, Armor Piercing, and normal: Only one should be activated at any given time, and will change a persons ammo to that type the moment it leaves the barrel of the players gun.

I’m not sure if this is just me, but the unlimited grenades doesn’t work.

1 Like

trainer makes the game very glitchy. for example, icons in menus don’t pop up, dialogue won’t pop up and i have to wait for it, fast travel loading screens play then freeze when the animation ends, (after the fast travel loading screen ends and i spawn) the game shows the fast travel icon (like if i was looking at the fast travel map in the previous subway) and it shows the previous subway minimap on the top right. after that, i have to pause the game and wait for it to fix itself. the map itself has some problems like freezing or just being wrong (ex: going from the surface to sewers, game still shows surface map). cutscenes that require spacebar to skip load forever and i am basically forced to watch it all. loading itself takes quite a while. i think those are all of the problems that i have encountered.

i know it’s not my pc because i lowered the graphics to the lowest and the problems were still there. i launched the game without the trainer and it worked fine, even with high graphics. i launched other games (modern and more graphics heavy) and i did not experience problems, even when i launched them with and without the trainers. i have deus ex installed in my ssd and the problems were still there. you get the point, i tried everything and the problems were still there until i launched the game without the trainer, then it worked fine. i was hoping the trainer could be updated to work better with the game so these glitches could go away.

yeah, been having this issue with the trainer for about 6 months now. no fixes, game is too old now for any trainer updates sadly