Dishonored 2 Cheats and Trainer for Steam

Nvm im just retarded it works now

Any news about a fix for Just curious. Looking at your list, looks like you have a massive number of games you have to keep updating trainers for.

Okay… got Dishonored 2… and then read on the notes to try it after the first mission. I tried it; Instant freeze
Mission 2: Instant freeze.
Mission 3: Instant freeze
And all three instances show “Not responding” in the task manager for Windows 8.1 But yet when I use … there’s no freezing. Now I’m paying the seven bucks and change to go pro on this to use the remote app with Infinity. I don’t like not getting or being able to use fully what I am paying for.

I also like to record my game play just incase of problems like this. Now the fact that the instant freeze and “Not responding” showing up on Task manager during three separate missions pretty much tells me that something is not right with this trainer. I don’t understand how it can worik for other people and yet not work for me. But I got recordings to back up my claims. as now since I tried to use Infinity with Dishonored 2 and endured the freezing. I’m going to have to restart the game and my system then continue using . and I really don’t like that. The ONLY reason I got this program or even instaleld it is that it was supposed to be the ultimate trainer to not need another trainer, to not have to go through megagames’s website or deal with sites where you have to pay to buy the trainer. Even with Andromeda i find it funny: Other trainers can work right off the bat right after loading the game, Infinity you have to start it when you’re on the planet’s surface. And now with Dishonored 2: work right off the bat, and yet, I’m running into problems with Dishonored 2 and Infinity.

I eagerly await your reply to resolve this problem

I just tested the trainer and it works perfectly fine. Used it in the second mission.

Now then let’s try to resolve your issue.
What is your game source? cracked/steam?
What cheats are you using?
Do you attach infinity after the game starts or are you starting it trough infinity?
let’s try first with those questions that should find an answer for your problem

(Raised sardonic eyebrow) 1: Steam 2: I wait until the game STARTS as in goes from main menu to in the game. Infinity was on but the play button was not pressed until I was in a mission, as I stated before Three separate missions made the game freeze up! Every time I tried to start the trainer in Mission one two or three, it would freeze the game up. I even switched it up in mission two, I started Infinity after I got to Mission two and right as I hit play; I had the task manager running in the same window and it immediately showed Dishonored 2’s status as Not responding. As for the cheats, I can’t even USE THEM! Every time I hit play on the Dishonored 2 trainer the game freezes and I’m forced to end the game and the problem is the same: Infinity. NOW that takes care of “What is your game source, cracked or steam?” “What cheats are you using” and “Did you attach Infinity after the game starts or from Infinity”

- ICDV2.bat - try using this to clear your cache maybe Infinity is using an old version of the trainer I doubt it but let’s just do everything that is possible.

Also use the Console of Infinity maybe it shows an error that might show the problem. Using Infinity Console

And leave your sardonic eyebrow down. Not helping the case

Add infinity to your antivirus exception list and disable it.

Wait, I always use infinity’s [Play] button to launch the game from infinity. If you’re starting the game first, how are you getting infinity to attach to process? Pardon my ignorance, I had no idea you could attach after launch, when I’ve run infinity after the game starts it never worked for me.

Just hit the play button

Yeah the play button can be confusing. It can be used to start a game and attach to a game.

1 Like

l’m wondering if it is possible to add inf. trait cheat into this trainer?

The inf. trait cheat on cheat engine’s table no longer works with the newest steam update and no one want to update it due to the games frequent patches. The same cheat on other trainers (like fling +15) no longer work also and even crash the game. lol

Just tried the cheat some time ago, and it seems the infinite coin is not working. The other cheats such as infinite mana worked just fine.

Infinite coins work fine , but you have to press J during mission and go to mission item to make it takes effect. You cannot use it in shop menu , it doesn’t work there.

Right. That did just the trick. Thank you :slight_smile:

Or read trainer notes.

Yes. Will do in the future. I apologize for being less observant. Thanks :slight_smile:

Any update yet? Most cheats work but I still can’t get any jump height. Hoping to play this game again soon. Been a while. Thanks!

Oh, i didn’t know it was broken. Will check it out

@mercury00 Turns out it’s a bug with infinity and not the trainer itself.

Can’t do anything until i talk to @frank about it when he wakes up

Hello could you add the options from dishonored 1 trainer to dishonored 2 trainer? (infinite blink distance, no cooldown)
People (including me) would love it.
Thanks for great work!