Dishonored Keeps crashing

The game keeps crashing whenever i try to enable the mods, i’ve tried to launch it in the mod but it doesn’t work, and i’ve also tried it by launching it in steam. Any Help?

Is your game version fully compatible with the Mod/trainer you are using ? Provide more details, and specify the game’s .exe file name as well.

Do you have the game on STEAM, or some other platform ? Post a screenshot of the Error.

Which particular Mods/options crash the game ? Try one option at a time, to confirm this, and provide proper feedback so that the developer can have a look into this.

If you have a different game source, other than for which the trainer was coded, the said Trainer may or may not work properly.

When you run the Infinity app/tool, make sure to run it as an ADMIN/Administrator, and temporarily disable any Antivirus/AV, as well as firewall on your PC.

You can also add “Infinity” as an exception/exclusion, if using any AV, but better turn it off, for the time being.

First launch the game via STEAM or otherwise, and then open the Infinity tool. If this doesn’t work, first launch the Infinity tool, and then start the game through this MOD, by clicking on the START button.

Try both these methods.

If need be, delete the infinity.sdf file which can be found under this OS location, C:\Users\Your username…\AppData\Local\Daring Development\Infinity\Storage\Cache.

Thanks it’s working now :slight_smile:

Cool. :slight_smile:

So, what was causing the crash ? AV/Firewall, or some other Admin related stuff ?

yeah, i had to add it to the exceptions and disable it then it worked :slight_smile:

Okay, that’s fine. Enjoy the game now.