Divinity Original Sin 2 trainer issue

I played my first game of Divinity with this trainer without any issues. However, it seems that on my second playthrough something has gone wrong.
To be specific, the cheats: “Unlimited Attribute Points”, “Unlimited Combat Ability Points”, “Unlimited Civil Ability Points” and “Unlimited Talent Points” are non-functional. They are the only ones that take effect when a level-up occurs and work in generally the same manner.
What happens is that they will turn on, but then immediatly turn off again.
I have noticed that the first time you try it after restarting the game is when it stays on the longest, if that is of any help.
All the other cheats work as intended.
I hope you find a solution quickly (or tell me what I might’ve done wrong), thank you in advance

ps: I saw in another comment that it had become necessary for more games to run in administrator mode, I tried this and it had no effect.

Is the game from steam ?
Or also sometimes your antivirus or firewall plays around with trainers too

After a few failed attempts, I think conclude that it was not adblock playing around with the trainers.
and yes, my gate is from steam

Excuse me, I read what you said wrong. I tried excempting infinity from the firewall, but that has also led to nothing