App Horizon

Dovahgolt: Custom Honeyside Manor [Major Mod] [Xbox 360] [DOWNLOAD]


#61

good idea thats kinda kinda what kitomi09 was implying, his idea seems better though because you can summon multiple things on command (by putting on the vampire armor or rings), where is followers tend to get lost


#62

did you mean the spectral dragon or an actual dragon?


#63

how do i download this?


#64

so excited for the next update


#65

Looks good. (: Keep it up!


#66

I cant summon on the latest version, im using the tenth divines save, any theories??


#67

I havent tried it yet bro abt to try it


#68

I see what you mean, only thing we can do is wait and see if rooster will make one more update to correct the issue


#69

of course, Ive seen someone on tuts saying it could be the resist magic 100% or something, a quick fix im sure, Rooster knows what he’s doing


#70

I had difficulty getting that to work.


#71

Try removing the Atronach perk on the Alteration tree.

Console command is player.removeperk 581F7


#72

sadly im on xbox . .


#73

Same here theres a thing with dragonborn where [details=Open Me]you can reset your perks its obtainable on the last mission against maraak[/details]


#74

also rooster theres the issue with all the weapons being one shot kill everything and the over powered spells dont get me wrong i love them but might i suggest a necklace or ring or even better something you can activate from the fav menu that way it can truly have some versatilityto enable them (talking about the spells) and also theres the issue with using the powers when using sunflare i tried to use it again but it dissapeared from the powers menu same thing goes for northwind


#75

How do I add the unobtainable items to my favorites list if I can’t even see them. I’m trying add the giant’s club, but I don’t know where it is. I apologize if this has already been answered. I didn’t want to go through 7 pages of comments looking for the answer.


#76

there’s 3 different saves, im assuming you chose the clear favorites menu, the other two saves have it just hit up on your directional pad to see all your options


#77

Thanks for the info. I also found a bug I think, the daedra companion is no longer in the place he used to be in. I had to do a quest which made him go home so the quest companion follows me, but he didn’t go back to Riften. Anyone knows another place he might be?


#78

Honestly its amazing. Great work to the creator must have been difficult :thumbsup:


#79

i see, just like all the other bugs hopefully rooster will look into it, he did say this one was final but i really hope he reconsiders cause im sure everyone enjoys the saves


#80

This is badass but is it possible to tell Miraak to shove-off? I don’t like him following me