Download fail horizon

hey guys,
i got a problem. i got horizon since three weeks and it runs without problems but since yesterday it says, that it isn’t a permitted win-32 application.

when i want to download i cant open it or it got 0 bytes.

pls help me sry for bad englisch.

Horizon is both a 32-bit and 64-bit program, so it should run.
Make sure you’re using a valid source for a download.
Try this one:

Horizon - CNET

i downloadet it from all sites i found. so this can’t be the reason :confused:

I just read a post, this has happened to another member. Please read this and maybe it’ll fix your problem:

Good luck. :smile:

It’s not a matter of which website you are downloading from, it is of the hardware your computer is running. If you go into control panel and system information you can see the details regarding if your computer is using a 32 or 64 bit OS.

thanks, the problem is that i dont know which download is the “fresh” one, but i will search a bit more…

Try this one, this is the Dev download so it’s fresh:

thank you if this doesn’t go, a friend can load it on an usb stick so i got a solution. :smile:

Do what pavman said. After opening Horizon v2.4, it will prompt you to update manually. Click yes, it will then start a download for Horizon v2.5.0.1. I had this same problem and Horizon v2.5.0.1 worked for me. Hope this helps.

This is the latest download for everyone having problems:

I’m having the same issue here, except when I download the updated version, it starts doing the same exact thing to me all over again. It’s literally an infinite loop right now. “Horizon failed to update. Manual update?” “Yes” … redownloads the same file and poof… "Horizon failed to update… "
I’ve even tried selecting NO to the update to see if it would just load up but it doesn’t. (and yes, I’m running as a system admin if that makes any difference)
Kinda weird since I’ve only had this program for 2 days and it worked fine both days

I have ran into this same issue. The application worked fine for a few days but AS SOON as i upgraded to diamond i noticed the upgrade tab in the app. I clicked it and I too am now stuck in this infinite loop. no matter what the updates fail. This really sucks cause it feels like I’ve wasted my hard earned cash.

same here…latest update (just downloaded the one from the developer a few comments before) and i get “Horizon was not updates, would you like to update manually?”…im sure they will get on it once they see more than one person has this problem :smile:

Edit - temp fix for now…disconnect your computer from the internet and it starts in offline mode…better than nothing :smile:

i am having a problem when updating, i’m downloading the newest version of horizon but it tells me: the program publisher couldn’t be verified. are you sure you want to run the program? i click yes and it takes me through the same process again. can someone help me?

im having the same issue now… but everytime i do the download it keeps looping me to redo it over and over…

im gettin same problem i go to re download and it tells me to manually update so i go to do so and click the new update one v2.5.0.1 and it is still tellin me to manually update again i took out all firewalls and even un installed norton still tellin me the same thing over and over