ELDEN RING Cheats and Trainer for Steam

It seems the modder has abandoned all future updates for the elden ring based on the comments wherein the trainer doesn’t detect the elden ring.exe running at all despite doing all the steps to disable ANTI-CHEAT.

1 Like

yo its not working for me I need help :')

I humbly request that this be updated so that it may be used once again, thank you.

The trainer is up to date.

Sending a call out.

Has anyone actually been banned yet?

trainer doesnt run for me. whenever i start the game it just says “were having trouble loading the mods into your game” and thats it. does anyone know how to fix that??

I assume you purchased your game on Steam. Please follow the read before playinginstructions provided by the trainer.

well stupid me i found my mistake :smiley: thanks

1 Like

Good to know you resolved it! :metal:

1 Like

Just a question, would you get softbanned for using one shot on enemies as long as you don’t mess with your characters stats or things with runes?

(I want to make a new character for shadow of erd tree and not use my NG+ save)

hey, hi. I did that but the trainer still doesnt run. Please help

Hi, might have overlooked something. Please try to redo it one more time.

  • Go to the game’s folder, where you can find the .exe file.
  • Create a new text file in that folder.
  • In the text file, type “1245620” (without the quotes) as the content.
  • Save the text file and name it “steam_appid.”
  • Launch the game directly using the “eldenring.exe” file.
  • After the game finishes loading, click “Play” in WeMod.

Hello @anirhkitskywalker, if you have time would you be willing to scroll up to the post I made on the 12th of March, with the same issue? I tried to be verbose when explaining what I did to try to make it work.

Although, I guess I could just use the quote function…

There we go, lol. So, I guess there’s no need for you to scroll up.
Is there anything beyond this that I can attempt? I’m a bit at a loss.



Oh, a quick edit:
As an extra note, I’ve also now wiped my drive and re-installed my OS. The above described issue persists on this clean installation of Windows 11.

ı delete and make the new text file but it still give me the same error :confused: :frowning: . Do you know if ı buy this game from xbox would differ or not?

Hello, it’s strange tbh, as you have already reinstalled your OS.
After following the instructions from read before playing, have you attempted to launch your game first on Steam instead? Once the game has loaded, switch to the WeMod app and press Play.

If it still persists, it could be an antivirus software interfering with WeMod. I would suggest you try adding exceptions for these two folders from your antivirus software :

C:\Users\%USERNAME%\AppData\Local\WeMod and C:\Users\%USERNAME%\AppData\Roaming\WeMod

I’m afraid the trainer is only compatible with the Steam version. You could try the recommendation above to see if it works for you.

Well … as per your response to RetiredStranger just now, I’ve realised what’s going on. My copy is also the Xbox version, which would explain why it cannot detect the running game. (The memory addresses are different, right?)

Also, even though it’s now irrelevant, I’ll go ahead and note that exceptions for WeMod are one of the first things I do on an OS re-install. Although I guess since you’re suggesting it, it’s not considered common sense like I assumed it was. I’ll start listing that as something I do, next time (or if) I have trouble with another game.

1 Like

it worked . thank you so much

1 Like

i used it on the convergence mod and it worked fine but when i started the regular game there was an error and it said that it cant load mods, so i tried to restart the game, deleted we mod and reinstalled it, deleted the game and installed again and im still facing the same issue.

Pls add easy teleport