Empire of Sin Cheats and Trainer for Windows Store

Empire of Sin
This is the official discussion topic of the Empire of Sin Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Enable Developer Mode


Important Notes:

Click here to view important information about these cheats.

Activate the cheat before loading a save. Once loaded, press ESC and select Developer Options>Cheats to use cheats. You must load a save for the trainer to work. If starting a new game, save the game and reload it to see the Developer Options, If your game exe name is “Empire of Sin.exe” then you have to reinstall the game, Game Exe name must be"EmpireofSin.exe" without spaces



Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 04/17/2021
    Started development

  • 04/17/2021
    Released trainer with 1 cheat

  • 07/31/2021
    Bug fixes and game compatibility improvements
    Updated notes



Like what you see?

Check out all of the games WeMod supports here.

The Empire of Sin cheats have been updated!

Changes:

  • Released trainer with 1 cheat



Please post in this topic if you run into any issues!

1 Like

When i click play on the wemod window, it opens the paradox launcher, i then press play and then wemod says that was unable to find the opened game

4 Likes

yep same for me

1 Like

I’m sorry to hear you are having issues with this trainer. Can you please try launching the game directly through the Windows Store then alt-tab and click play in WeMod? The game may be taking too long to load and WeMod is timing out.

Tried that, no luck. Wemod just reopens the paradox launcher…

Can we get an update on this please?

can we get an update plz?

1 Like

Needs an update and also will not work at all (doesn’t find the game exe).

When I tried to manually add the exe by drag and drop, it doesn’t work, even while the game is running. When I tried to add manually via FIle Explorer to pick the game exe, it says I don’t have permission to open this file.

4 Likes

This game STILL doesn’t work, huh? What’s the deal, Wemod? Get your acts together, maybe? I tried all of the above. Nothing worked. It can’t find the game (that’s running in the background).

1 Like

The file the game requires to manually turn on developer mode is not there at all.
X:\Users<User>\AppData\LocalLow\RomeroGames\EmpireOfSin\Settings.json
There is no settings.json to edit. I assume this is why the trainer will not work either.
Any ideas?

It still cannot find the game. I tried what was listed above and even manually dragged and dropped the exe file and it still cannot find the game.

wemod cant find game tried manually an or click play to open game neither work

not working at all

See for me it doesn’t say it can’t find the game. It just fails to connect to the game. Telling me: We’re having trouble starting or finding your opened game.

2 Likes

still not working

I think the windows version of this game requires an update. It’s not reading my game once its open

Since it seems like the trainer creator is busy with other projects… Here is how to manually turn on Dev mode for Windows version:
Open your file explorer and go to (C:\Users<User>\AppData\LocalLow\RomeroGames\EmpireOfSin) And inside the EmpireOfSin folder you will want to save a new text document. The text should be exactly as follows, including the brackets and being on separate lines:
{
“developerMode”: “true”
}
This^ is all you need in that text document. And then save it under the name: settings.json
Now the next time you open the game and either load a save or start a new game, when you press esc you will see developer options

The Empire of Sin cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements
  • Updated notes



Please post in this topic if you run into any issues!

1 Like