Error While Installing WeMod

Hey there guys! User2192359 here! I made an account here just to get help as I’ve tried everything I could think of and still can’t get Wemod to install successfully.

I jump on the website, download the installer, but when the installer gets to 100% I get this error

  • Unsupported 16-Bit Application -
    The program or feature “??\C:\Users*USER*\AppData\Local\Temp\WeMod-Setup-637491729660569676.exe” cannot start due to incompatibility with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

Then I hit OK and the installer says “Installation Failed”, and I get the option to use the offline installer. I click that, download the offline installer, but when I try to run it I get a windows notification saying “This app can’t run on your PC, to find a version for your PC contact the software vendor”.

Extra information, I have updated Windows 10, all drivers, restarted my PC, disabled Kaspersky and Windows Defender/Firewall and I still get this error.

It’s weird because it was working fine this yesterday but this morning when updating WeMod it got stuck updating on 25%, so I uninstalled and opted for a clean install of the latest version instead.

Any help would be greatly appreciated!

It’s possible the download cache is corrupted. I’m not sure what else the problem could be.

I uploaded the latest setup file elsewhere to test: **REMOVED**

Note: This was getting to many downloads and would rather hear directly from people that are experiencing problems with installing. Specifically the same error the OP had (Unsupported 16-Bit Application). Since the app has been updated, global caches should be fixed.

1 Like

Thanks Frank, I’ll jump on tomorrow morning and check it out!

1 Like

Hey Frank, I think that the download cache was corrupted. I was able to download and install immediately from the link you sent me. Just for extra information, the offline installer from the website was only 10.1 MB in size whereas the one you linked me was 82.9 MB.
Anyway, glad you helped me out and good luck fixing the download cache!
User2192359 OUT


Glad you got it working. Thanks for the info!

1 Like

THANK!!! it’s work