Error with some DLC files

No idea what exactly is wrong but as far as I know Borderlands 2 DLC’s are DRM Free, no?
So I got the files more than once already from different sources but everytime I try to put them into my USB I’m getting an error that says

‘an error has occurred while injecting’

'If you see a developer, tell him this:
‘The value of a data has been changed externally… bla bla’

Last thing is written in german, so can’t exactly tell what’s wrong other than the file seems to be unusable whatever I do.

Any ideas here?

They’re only DRM free if they’re the ones that came with the GOTY edition of the game or the add on content pack. Ones downloaded from Xbox Live have DRM protection.

Try dragging them into Horizon and save them to your device. When you try injecting them it’s signing them to a profile ID which you don’t want to do.

The ones at this link are DRM free, I’ve used them many times:

1 Like

First of all a big thank you, gonna try this stuff out now.
Though Mechromancer seems to be free now anyway.
There are 3 DLC’s missing on that list though. Sir Hammerlocks thingy, Tiny Tina and Vault Hunter 2, no?
Shouldn’t they have been included in GOTY? Or should I try and find them elsewhere?

1 Like

Only the stuff you got with the season pass was included in the GOTY edition. That didn’t include the Ultimate Vault Hunter Upgrade Pack 2 or any of the Headhunter DLCs.

I thought all of the DRM free stuff was available at that link but maybe it wasn’t or some was removed. But there’s a good chance the sources you used earlier are good but you were just trying to add them the wrong way.

I do have all the files on a hard drive so if you can’t find certain ones I’ll consider uploading them to Mega for you. I did this for others in the past but they get removed fairly quickly.

1 Like

Currently trying to save Cap. Scarlett to my device but no sign of progress showing, might end in an error again, maybe even same as before :confused:

1 Like

If you have device explorer open on the right side you should be able to see the green progress bar on the bottom. Large files take a while so be patient.

1 Like

Yup, just got the same error, no green bar. Maybe I should try a different USB

1 Like

Or try reinstalling Horizon. Have you used Horizon before for adding files and had success?

Also, are you dragging and dropping the files into Horizon and then choosing to save them to your device?

1 Like

Yes, it worked just 2 days ago for Skyrim saves

1 Like

would like to ask help on how to make the uhvm pack 2 work. I have all of the other dlcs that are included in the goty version of the game, but when i put the uhvm pack 2 and start the game, the game loses all the other dlcs. the maps are gone from the fast travel stations etc. do you know how to fix this? thanks, i have a jtag xbox if that helps. and the uhvm pack 2 im trying to install is the one you uploaded to mega so yeah…