Failed to Inject WeMod into RE2 (Resident Evil 2)

I am playing RE2 on STEAM, and wanna inject WeMod into it to try out different experience of it. However my WeMod just showing me failed to inject although I had added the exe file of RE2 into WeMod. I have no idea what is going on, I love WeMod, always use it to experience different things and gaming experience.

Hope this Issue will be looked into as soon as possible

Make sure you are using the trainer by MrAntiFun or Reppin. Not STN’s trainer because he no longer works with WeMod, so his is likely very outdated.

Press the down arrow next to the play button. Make sure the path to the game’s .exe is correct.


  1. Launch the game first via Steam.
  2. When you are on the main menu, alt+tab to WeMod.
  3. Press Play. Then alt+tab back to the game.

yep, I tried that , it still not working tho
Will it affected by the interent? Like internet security or something?

Once the trainer is downloaded into your computer (by using it with a game) it shouldn’t need the internet anymore.

However, the antivirus program on your computer can interfere with trainers. It’s generally advised to add WeMod as an exception in your antivirus program.

Really?dont need internet? Hv a look what hv I found at the left bottom corner when I disconnected from Internet from the imgur image link below.

Yes, some of WeMod’s features, such as voting for updates, require the internet.
But once a trainer is downloaded and used at least once then you can use it offline with no internet turned on.