"Failed to start game" with every game

Some relevant info first: I use Infinity on two computers, a desktop and laptop. It works fine in my laptop (Windows 8), but it keeps failing on my deskptop (Windows 7) since a recent update (from several weeks ago, I believe).

I’ve tried with many games (Comapny of Heroes 2, Age of Empires 2 HD, Payday 2, Dead Island, Plague Inc, etc…), I’ve tried reinstalling those games, the Infinity program, clearing it from registry before reinstalling, manually selecting the game’s .exe file, restarting my computer between these steps, etc…
Nothing seems to work so far, I keep getting the same error message for all my Steam games on the desktop computer.

DEP is disabled, so is antivirus, firewall, etc… None of the common fixes I’ve found in the forums or Help pages have worked yet.
Any ideas?

I suggest you switch to windows 10, you can use your windows 7 key to activate it. Try Infinity before you install a third-party antivirus, it should work.

Is there no way without having to switch to Windows 10? I’m not willing to change OS, Windows 10 is not to my liking as far as design, not to mention the privacy concerns.
I hope there’s another solution.

Some things you can try before reinstalling:

  • Uninstall any anti-virus with real-time protection that isn’t windows defender. (sometimes deactivating is not enough)
  • delete %appdata%\Infinity (this is the cache)
  • manually installing .net framework 4.7.2 (you probably have that already though since you can open the program)

If none of these things work, go into settings and save the log (directly after getting the error, without restarting or anything), then upload the log here.