App Horizon

Far Cry New Dawn Cheats and Trainer for Steam


#21

the God mode does not work at all for Far Cry New Dawn


#22

Having issues with this or it may just be WeMod in general. I’ve mapped the .exe for the game itself to the trainer and tried uPlay app but when attempting to launch either the WeMod app crashes and the game doesn’t launch.


#23

Make sure you are choosing the right one there are 2 of them steam and uplay versions

https://community.wemod.com/t/far-cry-new-dawn-cheats-and-trainer-for-uplay/80435/37


#24

The Health Mod has stopped working as of today 22nd of February 2019 on uplay Version 1.0.1


#25

I just used it like 2 hours ago because i use mega jump and mine worked fine
Steam version


#26

So there’s some weird stuff with health in this game, if you pop a med kit, it should go back to completely working :slightly_smiling_face:


#27

Can someone who are having issues with health mod send me their savegame files, you can find savegame files here

For Steam
C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegame<UplayID>\5211

For Uplay
C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegame<UplayID>\5210


#28

So this issue I can tell you from personal experience that it doesn’t persist through a game save, will happen randomly during play


#29

heres my uplay saves.
https://www.mediafire.com/file/rbzau00qqqbkqjo/5210.rar/file


#30

Thanks, downloaded. will look it up ASAP.


#31

Yes only after cutsceens need to use a med kit then you have unlimited health
Need to use medkit then it works fine


#32

Unlimited health isn’t working no matter what I do.


#33

It does. I play this all the time. Are using a med kit after enabling the cheat and after missions, cut scenes ?


#34

when i launch my game the wemod menu says we are having trouble adding cheats into your game try restarting or click help for help and clicking help does nothing


#35

Try to start the game first play for lil bit back out to desktop then click play in wemod after


#36

Anyone able to use an wired Xbox controller or PS4 wireless? All the sudden I can’t use one for new Dawn or fc5


#37

since the update yesterday the unlimited health does not seem to be working anymore, other than that great work thank you


#38

I dont think the " photo mod contest winner " broke the trainer
You using a med kit first ?


#39

As of 5 March, it’s only partially working, unlimited health is not working.


#40

Never mind, I see you have to use a med kit to get it to work. Thanks for the mod !