Final Fantasy III Cheats and Trainer for Steam

Final Fantasy III
This is the official discussion topic of the Final Fantasy III Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Mana
3. No Random Battles
4. Unlimited Items
5. Mega Exp
6. Set Gil
7. Set Job Level


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 03/16/2017
    Started development

  • 03/16/2017
    Released trainer with 9 cheats

  • 05/04/2017
    Bug fixes and game compatibility improvements

  • 05/16/2017
    Bug fixes and game compatibility improvements

  • 06/01/2017
    Bug fixes and game compatibility improvements

  • 05/16/2018
    Bug fixes and game compatibility improvements

  • 05/16/2018
    Bug fixes and game compatibility improvements

  • 05/17/2018
    Bug fixes and game compatibility improvements

  • 05/16/2020
    Unlimited Health cheat added
    Unlimited Mana cheat added
    Unlimited Items cheat added
    Mega Exp cheat added
    Set Gil cheat added
    Set Job Level cheat added



Like what you see?

Check out all of the games WeMod supports here.

The Final Fantasy III cheats have been updated!

Changes:

  • Released trainer with 7 cheats



Please post in this topic if you run into any issues!

Hello!

I have tried using the cheats and they don’t stay activated once I click the buttons and nothing happens in-game when I do. The only one that does turn on is the “No Random Battles” but it does not work. I have even restarted the app itself just in case, and still a no-go :frowning:

2 Likes

Hi and Welcome to the community

Are they turning off straight away again?
Are you using the Trainer made by @MrAntiFun as his is the most update version.
Are you using a Legit copy of the game? (Playing Through Steam)
Is your Game up to date?

  1. Yes, they turn off right away.
  2. I am using Mr. MrAntiFun’s trainer
  3. It is through Steam
  4. I actually purchased the game yesterday, so I believe it’s updated

When this happens its a compatibility issue.

Entirely possible the game has been updated again, even if it’s a hotfix this can have issues with the trainer. I would leave it a day or two and check again.

That makes sense. Thank you very much!

1 Like

I am having the same issue. When I press the buttons it makes a noise but does not do anything. Is there a update of this trainer coming out?
Do I have the timing of opening the trainer right? When do you open it? I could not find a FAQ area for that question.

I was having the same issue yesterday, and played normally until I had 4 party members. Today I just loaded the game & clicked status in game menu [didn’t select a character], then loaded the trainer & it is now working as intended

Can’t remember what ways I tried to get it working previously to narrow down a cause, but it could be either:-
it requires all 4 party members [very unlikely]
loading in a specific order
needs status menu selected [possible]

Good luck
~EDIT
Job level will only change top character slot, re-arrange party to edit other characters

It’s not working =/

No longer working. cheats turn off instantly when turned on. all cheats effected. will try again later and if working ill make a note here, otherwise i wont.

edit: attached the file FF3_Win32 to the play button and so far it is working

Hey i was having some trouble getting the job level to set properly. It seems to be only setting the level of the main character instead of the other 3 even if it is in the other peoples status menus. Do i need to just max all the job off of the main person or should it work for all

Umm, Hi. First time posting so please be nice. The cheats are working fine for me; health, mana, no random battles, items, gil and setting job level. The only one that doesn’t seem to be working for me in mega exp. I’ve tried opening up status and using the cheat that way, and at the end of battle when the exp is given out but still no joy. Any chance someone would be able to help me with this? Thank you.

add the exe (FF3_Win32) by urself and the cheat is working, but unlimited items can ■■■■ up ur save game, so care about that

How do I do that? I’m kinda a newb.

I’ve dragged and dropped the (FF3_Win32) to the play button and run the program from there but I still can’t figure out how to get the cheat to work.

Hello @Shygamrgrrl. :slight_smile:

If you have legitimately purchased the game from Steam then all you actually need to do is press the Play button in the trainer. This automatically detects and launches the game from your PC.

To activate the cheats you need to press the corresponding hotkeys on your keyboard while the game is running.

Hi Ravenfyre

Thanks for replying. I can assure you that my latest lot of bad decisions (ff3, 4, 5, 6 and 12) were the result of the recent steam sale. The rest of the cheats for ff3 work fine, although inf items only works when its feeling like it. I eventually did a work around and ended up using CE tō get max exp :grin:

I am Japanese. Please note that you are using a translation tool.
I tried using cheats in FINAL FANTASY 3 for Steam.
But none of the code is valid. Most of the cords turn off the moment they are turned on.
Pressing the button on the SET GIL has no effect.
Why?

↓ It is a video when using

Good evening

I just confirmed that all the cheat codes worked for some reason.
I’m sorry for making a noise.

yeah that doesnt work since thats how i launched the game trainer needs updating