App Horizon

Finding Games issue

i had to reinstall the app today but before i did , i did a clean wipe and even manually went in and deleted other lingering folders (as i found on other topics here) and that worked. but now it wont find any of the 300+ games i have on steam (which is located on another hard drive). I “fixed” some of them hoping it would “detect” the location for all the games but it hasn’t yet. Do I have to go through and manually "Fix each one individually? if so that’s gonna be so annoying.

edit: on another note, i also did the icdv2 clear that i saw as well, and while it did fix the issue of me even opening the app itself, hasn’t done anything for the finding game

Hmmm… Could be an issue with the recent changes to WeMod. Try changing to the Beta release channel:

image

Also try deleting the trainer folder and re opening WeMod:[C:\Users\YOURUSER\AppData\Roaming\WeMod\App\trainers]

This will force WeMod to ‘look’ for your games again and repopulate based on what it finds. I also have my games stored on a different drive than my boot drive and no issues thus far.

*Kill WeMod in task manager before deleting the folder

Post back with your results :slight_smile:

@frank Correct me if I’m wrong but this would be a registry issue right?

@bluebane2 Is Steam installed in C:\Program Files (x86)\Steam? In the steamapps folder should be a file named libraryfolders.vdf that stores the location of your other libraries. Does that file exist? Open it in Notepad to check the paths.

1 Like

The library folder doesnt have much in it
“LibraryFolders”
{
“TimeNextStatsReport” “1579101484”
“ContentStatsID” “-6695542310327418212”
}
that was all, i never had an issue with wemod until a few days ago… now its just wont work at all, even the games i added manually, the program wont “Activate” for that game anymore… i’ve tried some other small stuff i found elsewhere but it just seems like wemod does not wanna work for me. @User_N4m3 i also checked the folder you mentioned and there was no “trainer” folder in that location. maybe its just how i have steam set up, since its installed on my E drive while wemod is auto installed on C

I have steam games on a couple different drives and have no problems at all with wemod finding the games. Shouldn’t matter the drive.
Try with a new download after you end all in task manager
https://api.wemod.com/client/download

If you know how to use regedit, check out HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Valve\Steam and see what the InstallPath value is. If it’s not the E drive path, that’s the problem.

Does C:\Program Files (x86)\Steam exist on your PC? If it does, what’s in it?

Here’s a snapshot of what @frank is talking about:

My Steam install is on my drive used for games which is my B drive. Yours should be the E drive where your games are installed.

You mentioned that WeMod was working fine a few days ago. Did anything happen to your Steam library around that time?

1 Like

the install pathvalue is going where its supposed to to the steam folder on the proper drive. there is no steam folder on my c drive at all under programs (x86).
As far as what could have changed, I’m not sure i did change anything. wemod just suddenly stopped opening any trainers, so i went on the community and found others with a similar issues, so i followed what they did including some clean installs , as well as manually removing certain folders (i guess connected to wemod) from some places that may have lingered after the uninstall. afterwards, it just stopped finding any games, and i did a test and turns out even when i manually “fix” them, it still wont open the trainer.
just becoming slightly annoying now

Frank is actually working in finding the problem. Hard for him to duplicate the issue

Go to app settings, click the Save Log... button, and send me the resulting file over private message. I want to see if it’s the same problem somebody else is experiencing.

huh, so wemod had an update, did it and its apparently fixed it, after it restarted the games just popped up themselves and their even working now
i dont think i did anything to really fix it, the update must have? but i do appreciate all the help you all were willing to give, thank you

1 Like

Yes Frank pushed an update for a couple things he found.
Not sure if you had malwarebytes but seemed to be a problem with that

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.