For some reason Horizon won't start up

I uninstalled it, re-installed, getting the same error every time I try opening it

Would appreciate any help

Slap that HO

try deleting it and re downloading it and if that doesn’t work download it from a deferent browser like internet explore

Done… still being a *****

Tried that, and different versions, none work

Uninstall current version, install version linked in my signature.

Run horizon as administrator. If that doesn’t work, right click the icon, go to properties, and uncheck “block” or whatever it is. Apply and run as admin again.

Still not… it’s really odd, it’s the first time ever this happens


where the hell is the ‘delete’ on edits

View details, what does it say? Have you tried restarting your computer or checked if it needs to install uptades?

>.< Holy Schnikeys, that worked! Thanks! I thought I knew most of the ins and outs of my computer. I don’t think that anymore. Eternal gratitude!

I tried that too, this is what details says:

Do you have the latest .NET framework?

Have you installed any other modding tools since the last time Horizon worked? The only time I’ve ever had an issue was when I installed some other game editor app. After trying a bunch of possible fixes I thought to uninstall that app, and then Horizon worked again.

Another thing to try is to locate the Daring_Development_Inc folder and delete it. You can get to it by searching %localappdata% in Windows search, click on the Local result that comes up, and delete the folder mentioned above. Now try a fresh install from the link in one of our sigs.

I used it last night, and haven’t installed anything since then, it’s really odd
And yes, I just installed the latest version of .NET Framework but doesn’t seem to do anything

Try what Steve posted

Did that, still same error

This post was flagged by the community and is temporarily hidden.

Yeah I’m on Win7, I currently live in Canada, never had this error before in like 4-5 years so no idea what’s going on.
I guess I’ll reformat my computer and install Win10 while I’m at it, hope that fixes it

Thanks for the help though!

Roll back windows

The site switched over to HTTP/2 with SPDY yesterday (and a new SSL cert), so that may be causing this. I’m not sure how to diagnose it though. Do you have all Windows updates installed including optional ones for Microsoft products? There could be an update for the .NET Framework.