Forever Loading

Hello there.

Sorry to hear you’re having this issue.

Which game(s) are you trying to use WeMod with.
And which store did you get them from? (Or are they cracked?)

Thanks for hearing me out!
I’ve tested Persona 5 Strikers, Left 4 Dead 2 (which has worked in the past) and Phasmophobia (which has also worked in the past). These have all been launched from Steam and have not been tampered with or cracked in anyway

I am having the same issue. All my games are legit and are on Steam. I cant load any cheats thru WeMod. It constantly loads and never “hooks” into a game. It will launch a game but never loads. I have whitelisted, turned off antivirus, uninstalled/reinstalled WeMod, changed from stable to beta for updates. Nothing works. There is something on your guys end. Something got changed. I am no longer able to use your product. I guess I will go use Cheat Engine until you guys fix it. It is not just one game, its all games.

Well not sure but cant see how it’s in our end when 2 or 3 people are having the problem and 1000’s are not.
Try and start the games from steam store first then when you are in game alt tab out then press play in wemod after not before

Well I already tried that. It will not load any games. Even starting in steam first. I know you only see a couple people complaining, but we all have followed the troubleshooting steps.

How do you explain just all of a sudden the games wont load? Sorry but it is something you all should look into. When we have followed all the steps to remedy and its still broken, you dont just say “well not my problem because its only 2-4 people complaining”. You still look into it. Thats what support does. I have worked tech support. So please help us out or at least look into it.

Even then what you are telling me to do is not what the program advertises.

I should be able to click play, it loads the game and hooks in the cheats. Telling me that I have to start the game and then click play is do able and a workaround but it doesnt fix the issue that there is something wrong with WeMod.

1 Like

Hello @rregan00. :slight_smile:

Your issue seems to be somewhat different to the OP of this thread. The OP is playing games that recently have been updated and therefore the trainers are pending updates too. What games are you trying to use WeMod with?

I have tested the report with multiple games from Steam and Epic using up-to-date trainers, and I am unable to reproduce the reported issues at all.

The most common causes of this issue are:

  • You are attempting to use the cheats on a copy of the game that was cracked/pirated, as opposed to purchased legitimately or legitimately acquired in an official giveaway promotion.

  • You are attempting to use trainers in multiplayer game modes. Which is not what trainers are for, no matter where you get them from - for technical and legal reasons.

Because I am unable to reproduce the reports, please feel free to provide a log of your issue:

  1. Use WeMod until it fails.
  2. Go to the settings in the WeMod desktop app.
  3. Download the log as a .txt file and upload it to a reply in this thread using the upload button on the toolbar.

(For @AtlasRain)

I’m unsure about Persona 5 Strikers. The game’s developers don’t seem to communicate update announcements very well with their playerbase.

I am trying to run cheats on Dark Souls III and Dark Souls II: Scholar of the First Sin on Steam. Legit copies. I have disabled the Antivirus. I have tried to load the game first and then load the cheats. No dice. It just loads and then says:

“We are having trouble finding or opening your game”

WeMod-1615236878888.log (32.0 KB)

Hello and thank you for responding!
There were two other games that I hadn’t tried, being Half Life 2 and Portal 2, that didn’t end up working. At first, I thought it was a problem on my end because I had a problem with Steam not ending my games. After a reinstallation of Steam, I had tested and found out that WeMod was just could not launch games from Steam. For example I had launched Persona 5 Strikers with Steam and it went fine, but as soon I tried to launch from WeMod, the game wasn’t launching with it, like it has in the past. Im also getting a message at the bottom of my screen thats saying “An error occurred while installing an app update, retry”, perhaps that could be a clue? I think I’ve done what I could to whitelist it from from the firewall and exempt it from the antiviral software, but I may be wrong. Could you run me through how to exempt it from the antivirus and and I’ll get back to you on if it worked?

Thanks so very much for the help!

Your log states that the trainer’s injection into the game had timed out:

DEBUG [native] ResolvePath:15448 executed.
	0 "i:\\steamlibrary\\steamapps\\common\\dark souls iii"
DEBUG [native] ResolvePath:15448 completed.
	0 "I:\\SteamLibrary\\steamapps\\common\\DARK SOULS III"
INFO [trainer] Trainer ended.
WARN [trainer] Trainer launch timed out.

Give the following a go:

  1. Make sure the .exe for the game that is linked to WeMod is correct.
    To do this, click the down arrow next to the Play button in the trainer. Then navigate to where the game is installed on your PC and manually link the .exe.
    Don’t use the desktop shortcut as this is not the .exe - it’s a standalone launcher.

  2. Launch the game via Steam. Wait on the main menu for 5 minutes and then load your save game. Pause the game, Alt+Tab to WeMod to press Play.

  3. I also noticed that you didn’t click the links I gave you in a previous post above (there’s no “number of clicks” indicator next to them) about adding WeMod as an exception in your antivirus. Even when you disable an antivirus program, there are still some components running in the background. You should add exceptions.

Checking out the forum threads for these games here, nobody else as far as I can see has reported the issue of the game not launching. There are, however, issues with some cheats randomly deactivating. The Dark Souls series isn’t very cheat-friendly.

The exact steps depend on what antivirus program you use. They’re all different. :slight_smile:

If this has been done and there is still an issue, open your antivirus program and then go to the quarantine menu. If you see that a WeMod file has been quarantined despite adding it as an exception, whitelist and de-quarantine it from there. If you need instructions then Google can help there, since every antivirus is different. :slight_smile:

I am using Windows Defender. I added WeMod as an allowed exclusion process. I do not have anything in my quarantine. I have had the same games in the same folders for months and WeMod was fine. Then two weeks ago, WeMod stopped loading the cheats. So I am not sure it is on my end, It has to be something was changed with WeMod. I understand you have to go through triage and protocol for support, but you are not talking to a computer illiterate person. I have tried everything to get this to work. It has taken more time than I expected. I guess I will have to wait for you guys to figure it out.

None of the links relates to what I was talking about. It is not being blocked in Windows Defender and not in quarantine. I do not get a notice it is. I have gone through and excluded WeMod from Windows Defender. My games are all legit and I am not using pirated games. All of my games are Steam. And I am only using Steam trainers. Not using these in multiplayer. The last time the trainer for Dark Souls 3 was updated was end of January 2021.

So please can you try and look into what this is. I do not understand why this is so hard. None of what you have provided has helped. So please stop recommending steps that are not relevant.

Ok so I have tried waiting 5 minutes to then load the cheats. When pressing Play, it tries to load the program from Steam, after it is already running. I get a popup from Steam saying it is loading Dark Souls 3 after it is already playing. So there is something in WeMod that is trying to start the program instead of seeing it is already loaded and then loading the cheats.

@rregan00 Before looking into this further, can you confirm that manually selecting the EXE in the Play button dropdown and pressing the play button in there works?

Edit: Also, how many games have you tried? If only a few, which ones were they?

Look, when I manually add the exe, it still does the same thing. It tries to load and then says it cant find the game or it times out.

If you run the game first, and then wait 5 min, it will then try and load the game after it is already running. Steam pops up and says it is loading Dark Souls 3 AFTER IT IS ALREADY PLAYING. So WeMod is trying to run another process of the game instead of loading the cheats.

Dark Souls 2, Dark Souls 3, Dark Souls: Remastered

ah, so i have a different problem than our friend here, so i’ll explain mine when he’s done

@AtlasRain Feel free to explain now! This is your topic :slight_smile:

@rregan00 Are there any games that have worked for you? I am looking into this now and will provide an update shortly. I may have further questions.

@rregan00 Is your game’s installation folder (or Steam’s library folder) hard/soft linked to another location?