Freezes on play

So whenever i press play on a game in the app it loads me in and it freezes the display, I can still hear sounds but i can’t do anything. When that happens my mouse can still move but my keyboard doesn’t register and it’s just frozen.

Hello and welcome to the community. :slight_smile:

Which game are you referring to, and which store did you buy the game from (or is it cracked)?

Did you follow any special instructions that are pinned at the top of the trainer, if there are any?

And have you tried loading the game first, waiting until you are on the main menu, then alt+tabbing to WeMod to press Play?

To me this sounds like an issue with a lack of system resources. Such as insufficient RAM to run the game and WeMod at the same time, or an outdated GPU driver.

Hello, the game i am referring to is “The hunter: Call of the wild” which i bought from steam. There are no instructions or atleast i don’t see any and i tried loading the game first but it didn’t work.
My system has 16GB ram and my GPU is NVIDIA GeForce GTX 1660 Ti.