Game always worked, now crash

Hi guys! First of all my english sucks, please be patient with me :sweat_smile:
I have an issue with Dying Light enchanted edition, i’ve palyed using wemod without any problem till yesterday, this morning i tried to use “jump higher” and the game immediatly crashed. It’s ok so far, i don’t really need that, but since then the game keep to crash at the moment it start. If i start it from the game louncher it work propely but at the moment i start wemod it crash again, even with no cheat attive.

There was an issue yesterday that kept freezing WeMod app up when you tried to use it. Maybe it’s related. It was resolved really fast though. Try to uninstall the game, download the installer from here and see if that works

Make sure you are using a legitimately purchased copy of the game, not a cracked version. And make sure your game is up to date.

The trainer for Dying Light was updated 18 hours ago from this post (Dying Light Cheats and Trainer for Steam).
The trainer was made for the standard edition of Dying Light. It’s possible the enchanted edition may need its own separate trainer.

well i played for a couple of weeks with the enchanted edition and it worked fine, it could be the update have changed something though. So i guess i should move myself there… thank you for the help :smiley: