Games not launching

After update to latest version, games will no longer load, even if I specify the executable location. I run installer and the application as admin. I have another machine sitting right next to it which works fine. Same version, same games (same Steam account library). Prior to the latest update it had been working fine.

Log file has only this entry that I find interesting:

WARN [steam] Invalid ACF
0 “T:\sl\steamapps\appmanifest_203770.acf”

I’m not surprised by the warning, as that particular file doesn’t exist. I’m not sure why it is looking for it.

I have a second library location on another drive, which is where the games I am trying to launch are actually located. I have a few games in the library receiving the warning, so I will move those and delete the library and see what happens. But I don’t get any errors or warnings regarding the library the games I’m trying to launch are located.

I’ve uninstalled, cleaned the registry of any mention of WeMod, deleted anything in AppData\Local and AppData\Roaming, rebooted (three times, of course), but same behavior.

Couple of questions so I can continue troubleshooting:

  1. Where can I locate previous version offline installers?
  2. How do I disable automatic updates so I can see if latest version is actually the problem here?

Sorry you are having issues with WeMod. Older versions cannot be installed and you cannot disable automatic updates.

As far as the error, have you changed the location of your Steam install recently? I would need to double-check with @frank but I believe we use the registry key to get your main steam install location then use the info from a config file to find other directories where you have games installed. Inside each of those directories are manifest files that contain the app id used to launch the game.

What is the exact error message WeMod shows when starting a game? This sounds like an antivirus issue. Before continuing, please try disabling your antivirus or allow this file: C:\Users\%username%\AppData\Local\WeMod\app-7.0.13\resources\app.asar.unpacked\static\unpacked\auxiliary\WeModAuxiliaryService.exe

This is correct.

Thank you both for the quick replies.

There is no error message. If I click Play the text switches to Loading and the little animation just goes around and around. Game executable never launches. No third party AV on the box; I’ve disabled Defender Firewall to ensure that is not in the way. No changes to Steam install location or the library location where the game was installed. I can manually specify the executable location, but I get the same result.

Log does indicate that Windows Defender is the antivirus, even though I’ve gone and disabled it (or at least disabled real-time scanning). I added the executable you mentioned to the excluded list as well, but I get the same result. I do see WeModAuxiliaryService.exe is running after launching the main application.

Just to give a better idea of my environment:

I had two library locations: one on e: and one on t: (named e:\sl and t:\sl). The warning in the log I was seeing was regarding a manifest file in the library on t: that read:

WARN [steam] Invalid ACF
0 “T:\sl\steamapps\appmanifest_203770.acf”

The game was not installed in that library, however. I have since moved any game from that library to the other library (e:\sl) and deleted the one on t:, but now I’m getting that message for the library on e: with the same manifest name. That manifest doesn’t exist (obviously), but I’m confused as to why it would think it should. Maybe a fresh install of Steam? That would be irritating, but not the end of the world.

Warning now reads:

WARN [steam] Invalid ACF
0 “E:\sl\steamapps\appmanifest_203770.acf”

This is just from the log exported from within the WeMod app, which looks like it’s just a general log. Is there one specific to when it attempts to launch a game?

I have run a check on the integrity of the game files for the game in question (Foundation was the one I was attempting to launch when the problem first began, but it behaves the same way no matter which game I attempt to launch), and it comes back with no errors.

As I said in the original post, I have another machine sitting right next to it, and everything works perfectly. I know this is probably an irritating issue to troubleshoot, but any insight is welcome.

Thanks for the details. Let’s see if it’s actually the new version causing the issue. You can download the previous release here. Please delete AppData\Roaming\WeMod first though. The app will auto-update, but you’ll have enough time to see if the games work.

Is it still showing the warning for T:\sl\steamapps\appmanifest_203770.acf? The code basically asks Windows for the files in that directory, then reads them. It’s weird that it would be returning a file that doesn’t exist. Could it be hidden?

No on the warning to t:\sl\steamapps\appmanifest_203770.acf. After deleting that library, the warning switched to e:\sl\steamapps\appmanifest_203770.acf. I don’t know what is special about that file, but just noticed that it now exists in the directory (e:\sl\steamapps), and is apparently related to Crusader Kings II. So that whole thing may be a red herring. Did a file integrity check, came back clean.

At any rate, I went to download the file you linked above, and the connection was reset, which puzzled me. So on further consideration, I think now that you were close - it was a firewall issue. I was just looking at the wrong one. We have a Palo Alto on the edge doing URL filtering, and it didn’t like allowing connections to anything at for some reason, but just from this particular machine. I added it as a custom url, marked it safe, and boom - starts working. (Ok, so I’m playing at work. Just don’t tell my boss.) This was using

It’s puzzling that another machine sitting right next to the one having problems - on the exact same subnet - was working fine.

At any rate, thank you for the help, and sorry for the wild goose chase.

1 Like

That’s strange :thinking: Was it or that was causing the issue? Could you have been stuck on an older v7 version (not 7.0.13)? There were relevant bug fixes implemented in those patch releases.

The only URL exception I added was, since that was the only URL I saw mentioned as being blocked in the logs. It occurred to me yesterday that I had missed this as a likely explanation, because when I previously attempted the online installer it would fail and direct me to download the offline installer. So obviously the connections to the online installer packages were being reset. I’m assuming those are likewise at That probably should have tipped me off.

I was definitely on 7.0.13, as the offline installer I used was WeMod-7.0.13.exe.

At any rate, thanks again for the help. Like I said, just don’t tell my boss. :wink:

1 Like

No ! If your getting paid to work then … well you are using our product so I guess
I mean I’m on the forum here when I’m at work so guess we wont tell.
Where do you work at tho ? Lol

A post was split to a new topic: My game is not launching