Hard Drive: "Unformatted"

Got onto my 360 today - it took an abnormal amount of time to load, was stuck on the logo screen for a while. Loaded up after a while and signed me in.

Apart from my issues connecting to Live (that has to do with me upgrading to Windows 8 and having to reset my bridged connections) - my hard drive now displays as “Unformatted device”. I cannot alter it in any way shape or form without formatting it completely, which wipes it clean of all data.

I’ve researched this a little bit, and I’m hoping I do not have to do the inevitable. If anyone has encountered this problem or knows anything about it, please do assist! And yes I have unplugged it while off and on and reconnected; no difference.

I can still sign on and use my profile, in fact I am playing Reach online right now; however, I cannot view or do anything involving my hard drive. I cannot even choose it as a load device for games without having to format it first. I am reluctant to do this because I would rather not lose the countless hours of game data embedded within. This is a long shot; most of this community has no idea about hardware specs, but figured I would ask. Any intelligent help is appreciated!

Thanks guys.

Not sure if this will help at all but you could try clearing your system cache maybe.

It’s showing up as unformatted device on your Xbox 360? Have you tried to reset your xbox/turn xbox off, HDD out, put back in, xbox on?

Is it a slim hard drive? The same happened to me. It shown as unformatted then worked but shown everything as corrupted and then wouldn’t read/write anything.

It does not effect the hard drive since it is not being recognized as a Microsoft product.

Yes; yes I have tried all of those. No success.

Nope, original 360, same HDD I’ve had since launch in '05. Reach is working fine; however, Forza 4 is limited. All data installed to HDD by disc two and all DLC is now unreadable.

Yep same problem here except I have no data recognized from my HDD. Here is my thread on this https://www.wemod.com/forum/10-general-discussion/128157-need-help-hard-drive.html#post1154885

useing the tranfer cable to erase hard dreve and than put back on xbox

Hate to say it but it happened to me too a while back and the only way I could fix was to format. Sorry man.

Try backing everything up with Party Buffalo and formatting is all I can suggest. Eaton may be of assistance too. I usually nag ask him when something hard drive related ****s up as he has a lot of knowledge about them.

Hey guys have found a fix in which i have uploaded as a video tutorial to youtube.com was able to recover almost everything including games and game saves

3 years ago he would’ve greatly appreciated your help.

Your heart is in the right place . There may be people who are still experiencing this issue. Though previous poster is right, you might want to check post dates. They frown on resurrecting old posts on here.