Has anyone had this problem using WeMod?

If so I would appreciate a solution. I tried to play the Witcher 3 and Frostpunk but whenever I activated WeMod the screen would freeze but you could still hear sound. The games play fine without it. Not sure what could have caused this as this was never an issue before. I’m not sure what I can do to remedy this so again any help would be appreciated. I’ve validated files but the issue remains.

Are you running any antivirus?


Hello! :slight_smile:

Where did you get your games from? As in are they legitimately bought from a legitimate source or are they pirated/cracked? Be honest, we’re not here to judge. But if they’re pirated/cracked then there is a pretty high chance they are completely or somewhat incompatible with WeMod.

Wait until you are on the main menu before you activate any cheats. I’ve had an issue in one particular game where activating cheats while the intro movies were playing would trigger a media-related error message resulting in the game force-closing. But they worked fine on the main menu after the intros.
Also try launching the game first, then alt+tab to WeMod once on the main menu, press play then alt+tab back to the game.

Try disabiling your antivirus then uninstalling and then reinstalling WeMod from this link: https://api.wemod.com/client/download.
Then add WeMod as an exception in your antivirus before you launch it.

If you still freeze, try waiting about 10 minutes to see if the game unfreezes.


They were bought from steam. I will try your suggestions. Thank you for your time to help out a fellow gamer.

1 Like

Your suggestion seemed to work. However the next day I encountered the same problem without WeMod. I tried verifying files and uninstall/reinstall the game to only encounter the same problem.