Horizon beta not working on my 64bit computer

It wont work on my 64bir computer but it works just fine on all my other 32bit computers and laptops… idk what the problem is

You don’t have .NET Framework…

net framwork 4 and above install it

Ya just install everything they tell you to, also run in admin mode :wink:

working on my 64bit

I’m not 100% sure how it works, but I am pretty sure you can only have 3 different computers I.P addresses registered to your user name?

I have the .Net framework but Horizon still isn’t working

What errors pop up? I need more information other than “it’s not working”.

Are you on Windows 7 SP1?

How do i check?

Hold down the windows key on your keyboard (next to ALT) and hit “R”. Then type in “winver” without quote and hit enter.

Tell me the entire 2nd line of text with the version number.

Also, what anti virus do you use?

Version 6.1 (Build 7600)
Avast! Antivirus
I’ve tried shutting down my firewall and it didn’t change anything

Uninstall Avast, upgrade to v6.0 beta, or uninstall the behavior shield. There’s a major bug with it.

My Avast! works fine…I dont have the 6.0 beta, I have the stable version…

Grr Linux :smile:<3 Get that its amazing

He means uninstall the behavior shield. It doesn’t work with Horizon.

if your on windows vista or 7 click right mouse and start as admin maybe this will work because windows 7 and vista do not like to start some programs

Hey

I have the same problem and I only have 64 bit PCs!!!

When I open Horizon it says not working and checking for a solution???

I have .net framework 4 on Windows 7 Ultimate 64 bit (obviously) with build 7601.

Please help.

Thanks

P.S.

I have tried compatibility mode and run in admin

Do you have Windows 7 Service Pack 1?

You have Service Pack 1 installed. Uninstall it and it will work.

View this thread. https://www.wemod.com/forum/20-horizon-support/23839-horizon-crashing-loading-problems.html

This. Thanks Rizla.

Also to antonczuba, don’t bump a 4 week old thread.

Closed.