App Horizon

Horizon broken?

I’ve used horizon quite frequently over the last few years and never experienced any issues with it. I upgraded to diamond so that I could use the achievement unlocker. I tried to open it today and it said “failed to connect to server”. I’ve tried everything I could find on here as to what it causing horizon to not run and I can’t seem to figure it out. I am running windows 10, I tried with and without firewall on (never was an issue before) and I deleted everything horizon and redownloaded it and now I can’t even get it fully install and launch. Can someone please help???

Are you running any antivirus? Sometimes antivirus definitions update and block otherwise legitimate files and applications. If you are running antivirus, add the Horizon folder to the exception list: C:\Program Files (x86)\Daring Development\Horizon.

Let me know :slightly_smiling_face:

I have no anti-virus installed outside of the basic windows anti-virus. I fully removed horizon and tried to re-download it but now it won’t even do that. The install wizard says installation completed fully but there’s no shortcut on my desktop and it doesn’t launch even with the “launch application on exit” box checked on the wizard. I don’t even have that folder in my program files folder. I don’t understand what is going on. :frowning_face:

Can try this one and see
https://wemod.s3.amazonaws.com/horizon/setup/Horizon-Setup.exe

I’ve tried that link yesterday and just now and it keeps saying the site can’t be reached and that it sent an invalid response.

Do you want to do a TeamViewer session? If so, PM me your ID and Password and I’ll try to see what’s causing this.

It appears to be something with the internet in my new house. I took my laptop to my parents house today and horizon downloaded, installed and opened fine with no problems. Which is weird because I have used it at my new house prior to this happening and hadn’t had an issue before. :face_with_raised_eyebrow:

Is your ISP different at your house than at your parents’ house? If so, which ISP do you have (Comcast, Verizon, etc.)?

Comcast at both. This is so weird.

Comcast has added internet security to some users. You can disable it by doing this

  1. https://internet.xfinity.com/
  2. Click more then my services,
  3. Click Xfi advance security then disable it

If you disable it I suggest you call and cancel it since it is $5 or $6 per month.