Horizon download error (Hznam.exe-.NET Framework Initialization Error)

I just down loaded horizon and got the open file- security warning then i clicked run and a error window opened saying

Hznasm.exe-.NET Framework Initialization Error
To run this application, you first must install one of the following versions of the .NET Framework:v2.0.50727
Contact your application publisher for instructions about obtaining the appropriate version of the .NET Framework.

But the publisher is “unknown” so if any one else encountered this or any staff (or anyone else)know what to do please reply. Thank you

Are you using the latest version of Horizon?

And it’s your .NET Framework, as it says in the error, use version 3.5 that usually works fine, here’s a link to it: Download: .NET Framework 3.5 - Microsoft Download Center - Download Details

Do you have .net framework 3.5 installed?
Make sure you are running as admin, I would suggest reinstalling .NET 3.5 - Download Download: .NET Framework 3.5 - Microsoft Download Center - Download Details

how do u run as admin

4.3 DO NOT bump topics. Doing so causes unnecessary clutter to the forum.

A copy of the rules can be found here

Right click on the icon and click Run As Admin.

Closed.