Horizon is not opening all the way

every time i open, or try to open, horizon it shows the logo and everything. But then, it has me just sitting there, and it doesn’t open the window. I waited for it to load for a good half hour(didn’t open). I tried to uninstall and reinstall a couple times but that did not work, and no other modding tools work on my computer. I’m running on Windows 8. Please help me with this issue.


Most likely is your antivirus or firewall doing a mess, disable both and try to open again.

1 Like

ok ill try that

ok i tried it but it still did the same thing

try this link given by @frank to download horizon.


does the horizon process run in the background ? see the task manager to confirm if the app is still open in the background.

something like ctrl+alt+del imo. btw do u have .NET 3.5 framework installed as well ? reinstall OS maybe ??

It sounds like a connection issue; possibly CloudFlare messing something up. Are you able to go to WeMod using this link? https://horizon.wemod.com

1 Like