Horizon MB taking 5 - 20 minutes to recognize or read a USB drive in Windows 7

Hello everyone,

I am experiencing something in HorizonMB for the first time. As of this week it is now taking HorizonMB anywhere between 5 - 20minutes to read or recognize my USB flash drive. I have tried all the suggestions thus far but HorizonMB still acts the same and takes a significant amount of time to load the data from the USB drive.

Not sure what changed on your end but everything was instantaneous up until this week or the past couple weeks.

Things i’ve tried from the user end;

  • Reformat USB (fat32) and reconfigured device on xbox 360 for use
  • Long reformat USB (fat32) and reconfigured device on xbox 360 for use
  • Uninstalled HorizonMB / Reinstalled HorizonMB and updated to current version (non diamond sub) (run as admin ofc)
  • Tried different USB sizes from 2gb - 64gb (formatted and configured for xbox 360 use)
  • Tried these different USB devices on different usb ports even an external add on hub

Everything on the user end is fine and no problems, it’s only when I load up Horizon (run as administrator ofc) and try to load even just 1 .sav file and it still takes anywhere from 5 - 20minutes to access it.

If you could kindly look into it, i’m sure we whom are having this problem/situation would appreciate it.

thank you.

if you tried all those things then damn seems like it could well be a problem with your USB Ports or computer

I have the same problem and I also get this message when I eventually give up and X-Out can someone please put out some good information?

No sir, it would not be my usb ports/hubs because they read and register just fine on any device I plug into them. It only happens when I try to use HorizonMB and try to load up an xbox 360 configured usb device.

Do you only have this problem with horizon?

I myself have been having the same problem, but it seems like a global problem for a lot of people, even my teacher for mathematics is having a problem with her USB ports on her computer. She said her computer is not recognizing them either, which is really odd, so just be patient it is not a Horizon problem.

Same problem with me too…all programs I have used seem to be affected by this for me: Horizon, modio, even attempted a Witcher 2 editor that can read the USB stick through its own program…all take forever to load as of yesterday. Oddly my 360 HDD now reads faster.

Googling around I see that at least for Windows 7…for some reason the ports can get switched to USB 1.1 speeds…but that doesn’t explain why my HDD can read super quick.

It isn’t global, I have used a different drive (much smaller so I’m dissapointed) that works.

Its sad to hear that lots of people have this problem, its really a paint when you don’t even know what’s causing it. I guess you will just have to keep trying… :confused:

Past two days it is now back to normal for me…don’t know what was done differently. Flashdrive is back to normal speeds again.

it Hopefully just was a temporary malfunction.