App Horizon

Horizon Not Opening in Windows 10 Solution

Hi,

Recently I post a problem with horizon in Windows 10, and I find the problem.

The problem is a group policy setting that I import into the windows 10. When I make a clean installation of windows 10, I import Microsoft Security Baseline and NSA Cyber Baseline. And, one of the setting in NSA Cyber Baseline is causing the problem to run the Horizon. I will try to find what is the setting that is responsible for this problem, and I will updated this topic.

Sorry for create 2 topics to one problem.

If you want try fix the problem try to search in Google, How to reset Local Security Policy and click in ten forums link and follow the instructions to reset Security Settings in Local Security Policy (secpol.msc) and see if works. I’m at the phone now, when I get home, will upload the .NET Framework offline installer that I use.

Things to try before going insane:

  • Try running Horizon with administrator privileges.
  • Disable any antivirus including Windows Defender and try opening Horizon.
  • After disabling antivirus, uninstall Horizon and reboot your PC then reinstall from here: https://www.wemod.com/horizon.
  • Ensure all drivers are updated via the ‘Device Manager’ especially the video card driver.

Post back with results and if it’s still giving you issues, post the exact error or screenshots of what’s happening to help with troubleshooting.

I have try all of this and didn’t work, the program just don’t open. When I double-click don’t show horizon Logo, the problem is in the NSA Cyber I will remove it and just let the baseline from Microsoft.

Here’s the link for download the .NET Framework offline installer

Are you required to use the NSA cyber baseline or can you do without it? If you really need it, I can run it in a virtual machine and see if I can configure it to work with Horizon, but it may not be until tomorrow when I get home from work (5 pm EDT). Are you going to be running this in a Windows 10 or Windows 7 environment so I can test?

Also, can you tell me what steps you are taking with the baseline?

I just use the NSA Cyber Baseline for extra layer of protection in my computer , and I use together with Microsoft Baseline.

The steps that I follow was the steps provided here

I run the command RemoteSigned first
and them I use the command that are in the link.
The order is

1 - Run powershell as admin
2- Run Remote Signed command. and them type A
3 - Paste the command CD %userprofile%
4 - use the command cd Downloads
5 - unblock the zip file downloaded in GitHub page
6 - Obs: Put the zip file in downloads to work correctly
7 - Extract the folder from zip file and remove - master
8 - Now Import the module l, using the command in the link
9- Import the settings to standalone system and domain

I do all this , now horizon is working perfectly I had to stop use the NSA Cyber Baseline, couldn’t find the problem probably is the way Executable Files are configured in Local Security Policy

I’m using Windows 10 1903

I use the following commands in the order to import NSA Cyber Baseline

1 - Set-ExecutionPolicy RemoteSigned
2 - cd $env:USERPROFILE
3 - cd Downloads
4 - Unblock-File -Path ‘.\Windows-Secure-Host-Baseline-master.zip’
5 - Get-ChildItem -Path ‘.\Windows-Secure-Host-Baseline’ -Recurse -Include ‘.ps1’,’.psm1’ | Unblock-File -Verbose
6 - Import-Module -Name .\Windows-Secure-Host-Baseline\Scripts\GroupPolicy.psm1

Applying the SHB policies to a standalone system

7 - Invoke-ApplySecureHostBaseline -Path ‘.\Windows-Secure-Host-Baseline’ -PolicyNames ‘Adobe Reader’,‘AppLocker’,‘Certificates’,‘Chrome’,‘Internet Explorer’,‘Office 2013’,‘Office 2016’,‘Windows’,‘Windows Firewall’ -ToolPath ‘.\LGPO\lgpo.exe’

Applying the SHB policies to a domain

8 - Invoke-ApplySecureHostBaseline -Path ‘.\Windows-Secure-Host-Baseline’ -PolicyNames ‘Adobe Reader’,‘AppLocker’,‘Certificates’,‘Chrome’,‘Internet Explorer’,‘Office 2013’,‘Office 2016’,‘Windows’,‘Windows Firewall’ -ToolPath ‘.\LGPO\lgpo.exe’

Ok, I spun up my virtual box and have everything the way you described. I installed Horizon and can now replicate your issue. I will post back with a solution if I don’t go crazy first :smile:

1 Like

So, after a few hours going insane trying to figure out what is blocking Horizon from running with ‘Applocker’, I still have no idea what is causing this. What’s weird is I can install and run WeMod just fine and any other app that is signed. I started the ‘Horizon.exe’ from CMD and here’s the result:

It seems so execute successfully, but it doesn’t yell at me saying it’s blocked by Group Policy either.

I checked every possible setting in Local Security Settings and Local Group Policy Settings and came up with nothing even after creating several rules that would otherwise allow “Horizon.exe” to run without a hitch.

For those who are wondering what is going on:

@masuhirogamer is using something called ‘Microsoft-Security-Baseline’ which acts as a local antivirus by preventing certain programs from even reaching memory to be loaded which is usually ideal for business environments where blanket rules can be enacted. The issue we are running into is ONLY ‘Horizon.exe’ will not even open (task manager shows it run for a second then the process dies).

The Windows security feature that acts as the console for ‘Microsoft-Security-Baseline’ is something called ‘AppLocker’ which lets you create rules to blacklist or whitelist anything from .DLL files to installer packages. I have created rules that whitelist ALL files everywhere on the PC for ALL users and Horizon still refuses to execute successfully.

With all of that said, I leave this open to the brave soul who can solve this case. I would do this in a virtual environment since you won’t want to subject your own PC to this.


All instructions and download links are in the above posts. Be sure to read the readme.txt files as they have crucial information for replicating our results.

~ Nate

Hi,

I have a problem with horizon in Windows 10, before I create this topic , I have search in the community for solutions but it seems none of the solutions that have the same problem as I do worked.
In Windows 10 1809, I install .NET Framework and also installed all the Microsoft Visual C++ 2005 to 2019. When I was in windows 10 1809, I have installed all the updates and still not opening Horizon. After some days of use, Windows Update show the update for the Windows 10 1903 and them I update and the program just opened but the update was lag my computer so I decide to make the clean installation and install the same updates as I do before.
But, in the final don’t work and I can figure out, what is the problem. Today I’m in Windows 7, can you guys look into this problem please.

Can one of the mods close this or merge with current thread: Horizon Not Opening in Windows 10 Solution.

Thanks @ptondo!

1 Like