Horizon (Not recognising my usb)

As it says in the title, Horizon will not aknowledge the usb.

Its been formatted as a 360 storage deviceand has my Tiger Woods save in it but will not load the device.Ive used it countless times before.

Ive reloaded and reformatted the usb countless times and have also redownloaded Horizon and installed again but to no avail.

Feel like Im missing something obvious, Can anyone shed any light please?

Thanks in advance.

Are you getting some sort of error? if so plz post

Also be sure your running the program as an administrator, sometimes the device explorer doesnt work unless you are

Are you running Horizon as a administrator?

If not… do it now.

Forgot to mention yes I’ve ran it as admin and still nothing. When I try to manually open it it says no xbox storage device connected.

No error coming up at all. It’s just not aknowledging that the USB is connected although my comp can see it. Horizon can’t.

Try putting it in a different USB port.

First thing I did mate. :smile:

Just tried opening it in party buffalo device explored and Modio. No joy. Same outcome.

I know it’s not the programs as they are all the same outcome.

It’s not the USB ports as when I go to my comp I can see the USB connected.

Problem us none of the missing programs recognise the USB as a 360 storage device?

Hmmm. This is quite a pickle.

Can you access the USB normally? Like open it through My Computer?

Yes, the ports reading the USB but none of the nodding programs are recognising that it’s a 360 storage device. I used the same USB stick Sunday night and have done for months.

It’s got me baffled.

Do you have another USB? Try that one if you do.

First put all your saves from your USB to your 360 HDD and reformat your USB to Fat32 on your PC and then reformat on your 360 and it should fix the problem. I had a problem like this earlier this year and this fixed it for me.

I see a similar problem sometimes on my laptops (I think it is a windows issue). I know it should come up okay, but what I sometimes have to do is reboot the PC with the usb out, then when windows finishing loading , run horizon and put in the usb. That seems to fix the issue at least temporarily. Good luck.

1 Like

I appreciate everyones time and effort for trying to help.

Not exactly sure what the problem was but it seems to have actuall resolved itself, Only thing I did differently was configure the usb on my upstairs xbox??

I’ve thanked people accordingly.


Glad to hear it was fixed for you.

Only thing I can think of is this:
Disable your UAC then try again, to get to this in your windows search bar type in UAC then click on it, it should bring up a window like this

Then once on there drag it down to never notify, you will require a system restart after doing this.

Edit: I’m an idiot, didn’t notice the problem was fixed. Delete this reply.

Appreciate it nevertheless Jimmy and regards Lessthan3 :wink:

Not exactly sure what the problem was but it seems to have actuall resolved itself