Horizon not working

horizon stopped working for me when the last update came out v2.0.1.3:

i have windows xp and i have .net framework 4

i have already tried

Delete and re-download Horizon
Install .NET Framework 4 (Or Uninstall all versions, and install again)
Take Ownership of Horizon
Make Horizon an exception to EVERY firewall and anti virus you have.
Open Horizon and Task Manager, and on the memory tab, it should be around 50,000k used. (In not, it’s being blocked)
Run in Compatibility Mode (Windows XP or Above)

what Service Pack are you running?

service pack 3

You may want to try these 2 methods;

[details=Avast Fix!]Avast 6.0 Download!
Please download it, it’s a fix. Tested by Cheater! Also if you prefer Avast 4.8/5.0 Uninstall Behavior Shield


[details=Oscars Fix!] I thought I’d have a look into why Horizon wasn’t opening for me and managed to find a solution, this should help others with the same problem too.

To fix open up regedit (RUN prompt, type regedit) and browse to the “Image File Execution Options” subfolder located at:

[b]HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion[/b]

You should see a folder called “Horizon Beta.exe”, delete that folder and Horizon should run again!

Those are taken directly from the sticky of this section; https://www.wemod.com/forum/20-horizon-support/23839-horizon-crashing-loading-problems.html

i have norton

Have you added Horizon to an exception list in Norton? Norton picks Horizon up as a false positive, so it should auto-delete when you try and run it if you haven’t added it to an exception list.

Go to Settings And then it should look like this:

Click the Plus next to each exclusion and add the directory of where horizon is installed/located. In my case, Horizon is located in a folder called Horizon inside a folder called Modding located on my Desktop.

So…you did everything but run as admin?

He is on Windows XP. You can’t run anything as admin. You can only have an Administrator account. Atleast, this is true on SP2, I’m not sure about SP3 but I’d think it would be the same.

You need .net framework 3.5. 4.0 does not include 3.5 according to cheater so make sure you have it installed also.

Alright my bad I haven’t used xp in years…

I have 4.0 I already tried reinstalling 4.0

YOU NEED 3.5 not 4.0! 4.0 does not include 3.5 which is needed to run horizon. So install 3.5 and uninstall 4.0

If you have windows xp then why does the message in the program looks like Windows Vista?

You can refer to my horizon support in my signature. This will explain most issues

Yes, you need 3.5 and 4.0 net framework. 3.5 is required to run it.

Probably a theme.

Like Chris said, you need .NET Framework 3.5.

Try this downloading and installing these.

.NET Framework 3.0 (XP Only)
.NET Framework 3.5
.NET Framework 3.5 SP1
.NET Framework 4.0

i just installed .NET Framework 3.5 and its still giving me that same error

Ok try this:

Delete Horizon data

[details= Horizon Data Fix]Sometimes horizon will have problems or errors caused by various things. This is not normally a problem with they way its coded, Could be a variety of things. Try Deleting horizon data from the appdata folder. You can do this by following this Simple Steps:

  • Click Windows Button(Bottom left normally)
  • Search for Run
  • Open and type ‘%Appdata%’ Without Quotations
  • This will open a Folder, Navigate to Local/XenoCode/Horizon and Delete the Horizon Folder. Once Finished, Please go to XboxMB - Xbox Message Boards - Horizon and Re download Horizon.
  • Once Downloaded, Please Open Horizon.exe. This will Re install these files you have deleted.

Detailed Instructions:

delete Horizon Data

Click the Start Button, If you dont know what that is, Its normally bottom left. It Says start in Windows XP, And in vista and Seven Has 4 Cloloured Flag looking things. CLick it and there should be a search box…

In the search box, Type RUN

You should now have this box:

Type in the Highlighted Blue area, Exactly this:

Copy and paste that.

This should Open:

Or something like this. Click On Appdata At the Top
Now Open Local Folder
Now Open Xenocode
Now Open SandBox

Right Click on Horizon This should Appear:

Click on Delete, Normally 3rd From the bottom, Above Rename

CLick on they Yes Button

Now Please go to XboxMB - Xbox Message Boards - Horizon

Click Download Horizon Here:

Save this to Desktop, Now Open Horizon.exe
This will now Install the files you deleted.

The Other Way is:
Click Start
Open My Computer
Open: C:/users/YOURUSERNAME/
Click ALT Key
Click Tools
Click Folder Options
Click View
Find and Click Show Hidden Files Folders and Drives.
Appdata Should Now be Visible
Open Appdata
Open Local
Open Xenocode
Open Sandbox
Right Click Horizon
Click Delete

Now Please go to XboxMB - Xbox Message Boards - Horizon

Click Download Horizon Here:

Save this to Desktop, Now Open Horizon.exe
This will now Install the files you deleted.


still not working

Try running another .NET program such as Modio.

modio works fine thats ive been using 2 extract my save since i cant use horizon and fatxplorer requires NET Framework 4