Horizon on a Mac :/

So I downloaded Horizon.exe, used both Crossover and Wine, and I’m only getting errors :confused:

here is what I got:

any help? :anguished:

[details=Open Me]###BOTTLING### default.sh
###BOTTLING### Gathering debug Info…

Versions
OS…: darwin11
Wine…: 1.1.44
WineBottler…: 1.1.44

Environment
PWD…: '/Applications/Wine.app/Contents/Resources/bin’
PATH…: /usr/gnu/bin:/usr/local/bin:/bin:/usr/bin:.
WINEPATH…: /Applications/Wine.app/Contents/Resources/bin
LD_LIBRARY_PATH…: /Applications/Wine.app/Contents/Resources/lib:/usr/X11R6/lib
DYLD_FALLBACK_LIBRARY_PATH…: /usr/lib:/Applications/Wine.app/Contents/Resources/lib:/usr/X11R6/lib
FONTCONFIG_FILE…: /Applications/Wine.app/Contents/Resources/etc/fonts/fonts.conf
DIPSPLAY…: /tmp/launch-ID1Z3a/org.x:0
SILENT…:
http_proxy…:
https_proxy…:
ftp_proxy…:
socks5_proxy…:

Hardware:

Hardware Overview:

  Model Name: MacBook Pro
  Model Identifier: MacBookPro4,1
  Processor Name: Intel Core 2 Duo
  Processor Speed: 2.5 GHz
  Number of Processors: 1
  Total Number of Cores: 2
  L2 Cache: 6 MB
  Memory: 3 GB
  Bus Speed: 800 MHz
  Boot ROM Version: MBP41.00C1.B00
  SMC Version (system): 1.27f3
  Serial Number (system): W880821MYJY
  Hardware UUID: E285DB00-33C3-5DA6-BC50-AAC50B9BE9FF
  Sudden Motion Sensor:
      State: Enabled

###BOTTLING### Create .app…
###BOTTLING### Turn on Coreaudio…
fixme:system:SetProcessDPIAware stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33c934
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:advapi:SetNamedSecurityInfoW L"C:\windows\system32\gecko\1.0.0\wine_gecko\components\xpti.dat" 1 536870916 0x0 0x0 0x2156f4 0x0
fixme:iphlpapi:NotifyAddrChange (Handle 0xa82f528, overlapped 0xa82f530): stub
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:advapi:SetNamedSecurityInfoW L"C:\windows\system32\gecko\1.0.0\wine_gecko\components\compreg.dat" 1 536870916 0x0 0x0 0x1f59d5c 0x0
wine: configuration in ‘/Users/BuddyBear/Desktop/Horizon.app/Contents/Resources’ has been updated.
###BOTTLING### Sandboxing…
###BOTTLING### Enabling Antialiasing…
###BOTTLING### Installing Truetype Fonts…
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Arial Bold Italic.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Arial Bold.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Arial Italic.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Arial.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Brush Script.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Times New Roman Bold Italic.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Times New Roman Bold.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Times New Roman Italic.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Times New Roman.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Verdana Bold Italic.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Verdana Bold.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Verdana Italic.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Verdana.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Wingdings 2.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Wingdings 3.ttf: File exists
ln: /Users/BuddyBear/Desktop/Horizon.app/Contents/Resources/drive_c/windows/Fonts/Wingdings.ttf: File exists
###BOTTLING### Registering Truetype Fonts…
/Applications/Wine.app/Contents/Resources/bin
###BOTTLING### Registering native dlls…
###BOTTLING### Installing Horizon.exe…
fixme:module:LdrAddRefDll 0x41910000 flags 1 not implemented
wine: Install the Windows version of Mono to run .NET executables
wine: Unhandled page fault on write access to 0x00000000 at address 0x4048e9 (thread 001a), starting debugger…
couldn’t load main module (2)
Unhandled exception: page fault on write access to 0x00000000 in 32-bit code (0x004048e9).
Register dump:
CS:001b SS:0023 DS:0023 ES:0023 FS:1007 GS:000f
EIP:004048e9 ESP:0032f1cc EBP:0032fee8 EFLAGS:00010216( R- – I -A-P- )
EAX:00000000 EBX:00405010 ECX:0032f028 EDX:00110064
ESI:0000001c EDI:00000000
Stack dump:
0x0032f1cc: 00400000 0000001c 008a8064 00000000
0x0032f1dc: 00096d2f 00000000 00000000 0040420f
0x0032f1ec: 7ffdf000 7b849635 00000000 00388f1f
0x0032f1fc: 00000000 00000018 00330000 0000001c
0x0032f20c: 00036d13 0006c400 00400000 00060000
0x0032f21c: 00000000 00000000 0000001c 008a8064
0200: sel=1007 base=7ffc0000 limit=00000fff 32-bit rw-
Backtrace:
=>0 0x004048e9 (0x0032fee8)
1 0x7b84966e in kernel32 (+0x3966d) (0x0032ff28)
2 0x7bc5e84c (0x0032ff48)
3 0x7bc5f3eb (0x0032ffc8)
4 0x7bc3b3ed (0x0032ffe8)
0x004048e9: addb %al,0x0(%eax)
Modules:
Module Address Debug info Name (21 modules)
ELF 0- 4000 Deferred <wine-loader>
PE 40590000-40594000 Deferred advapi32
PE 40790000-40797000 Deferred shlwapi
PE 41910000-41913000 Deferred mscoree
PE 42910000-42914000 Deferred rpcrt4
PE 429a0000-42ac9000 Deferred shell32
PE 42ba0000-42bd6000 Deferred user32
PE 42ce0000-42ce4000 Deferred gdi32
PE 42d80000-42d93000 Deferred comctl32
PE 43060000-43064000 Deferred winex11
PE 43260000-43264000 Deferred imm32
PE 432b0000-432b4000 Deferred uxtheme
PE 43430000-43434000 Deferred ole32
PE 43590000-43594000 Deferred mswsock
PE 435a0000-435a4000 Deferred ws2_32
PE 435d0000-435da000 Deferred wininet
PE 43660000-43668000 Deferred mpr
PE 43690000-436aa000 Deferred crypt32
PE 43730000-43734000 Deferred oleaut32
PE 7b810000-7b8c0000 Export kernel32
PE 7bc10000-7bc14000 Deferred ntdll
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
00000016 0
00000015 0
00000014 0
00000010 0
0000000f 0
00000011 winedevice.exe
00000018 0
00000017 0
00000013 0
00000012 0
00000019 (D) Z:\Users\BuddyBear\Desktop\hznasm.exe
0000001a 0 <==
0000001d explorer.exe
0000001e 0
Backtrace:
=>0 0x004048e9 (0x0032fee8)
1 0x7b84966e in kernel32 (+0x3966d) (0x0032ff28)
2 0x7bc5e84c (0x0032ff48)
3 0x7bc5f3eb (0x0032ffc8)
4 0x7bc3b3ed (0x0032ffe8)

LOG ### Command ‘/Applications/Wine.app/Contents/Resources/bin/wine /Users/BuddyBear/Desktop/Horizon.exe’ returned status 5.

###ERROR### Command ‘/Applications/Wine.app/Contents/Resources/bin/wine /Users/BuddyBear/Desktop/Horizon.exe’ returned status 5.
Task returned with status 15.[/details]

>.< You serious man?
.exe = Executable AKA Mac’s don’t support them.
You’re not allowed to use Horizon on a mac.
+1 for pc users.

That is why he mentioned he tried using wine/crossover, it allows you to run .exe’s inside an OS that doesn’t support .exe’s.

Anyways, have you tried using virtualbox and installing windows that way, It would probably be much easier. I highly recommend virtualbox over wine or crossover.

Note: Wine always gave me problems as well as I use linux for most everything I do. (VB solved all my problems though…)

Oh, didn’t see that. Bootcamp also works. I dualboot Win7 and Linux tho, so i don’t have a problem.

It won’t run in Wine because you need .Net.
Use Parallels or Bootcamp.

Alright, ill give both of those programs a try, thanks for the help guys (: if i run into more problems, ill give you guys a shout out.

Also, im very new to all of this, looks entertaining, so do you have any tips for things I should absolutely avoid while modding? Like achievements, market place items (such as weapon skins on GoW3) etc. im just doing this to have some fun, see what all i can mess with.

Don’t know my do’s and donts. I know everything comes with some level of risk.

Modding offline my best option?

Im going to be playing with Reach and GoW 3.

I use parrells with windows 7 it runs smooth and it works just like a windows would if you want to use Windows applications you can bootcamp your computer but it’s risky and you have to partion your drive I used to have my computer like that but now I just use parrells it’s a lot easier to setup and launch

VMWare Fusion Virtualization Tool

Straightforward from there.

Edit: I’m not sure if you have access to a terminal in OSx. If you do and have knowledge of it, you can try this: http://appdb.winehq.org/objectManager.php?sClass=version&iId=9828 with both the args dotnet30 and dotnet35.

Wine doesn’t support .net after 2.0 and hasn’t for quite some time you’ll need either parallels or VMfusion, you can also bootcamp which is cheaper and would work more efficiently.

Incorrect.
Wine does support 3.0 and higher.
They’re unstable, but possible.
See my edit above.

Wow YOU FREAKING IDIOT >_<

+1 For Mac users!

Except that Mac’s version of .exe is .dmg and is not commonly supported.
Your argument fails as much as the operating system you’re backing.

I don’t see how Mac’s fail, I play Bad Company 2 and a calcavade of other games on my Windows 7 Bootcamp drive. Along with a well designed and modern look Mac’s can do anything windows can.

No, OSx alone cannot do half of what Windows can.
You need a virtual machine or wine to do nearly anything useful.
OEM OSx is worthless.

Edit: That, and if you actually bought a mac, I feel bad for you.

When using crossover did you install the .NET framework within crossover?