Horizon Problems From The Get Go

Unfortunately, I have had nothing but trouble from this program. First, I had trouble downloading horizon.exe. Disabled my firewall, so then I was able to get that, but not until after I had it tell me several times that “This is not a valid Win32 program” even though I’m running WinXP. Then, it starts to download, but when it gets to 2/3 done, then a “script error” bubble pops up asking if I want to “debug the script” It says click NO if i’m not testing the website, then downloading stops altogether. I have to close out the download with Task Manager with a message telling me the program isn’t responding. I though, well hey, there has to be valid alternatives like modio right? Wrong. Modio gave me the same Win32 error message, I tried 360Revolution, but I get to the part where I login to download, I login, and then nothing. Nothing loads, nothing shows up in my downloaded software, its just not there, I even tried Leazon or whatever it is, and still nothing. I see people saying its an awesome program, it works great, so why am I not seeing this? Why am I having such a hard time?? I am trying to TEMPORARILY download a modder so that I can load ONE. SINGLE. Downloaded Minecraft map onto my Xbox360, but i just can’t. I have literally been at this for over 15 hours now. Is there anyone that can possibly explain where i’m going wrong or what else I can try?

Try downloading from this link: https://www.horizonmb.com/client/v2/latest.php
Also make sure that Windows has all its latest updates, and make sure you have .Net Framework 3.5 installed.