Horizon running offline when it is on v2.8.0.0

Hi horizon keeps running offline and it says failed to connect to server i had this problem before i updated it to v2.7.9.3 but now it just dose it now all the time i uninstalled it disabled my firewall and my anti virus but no just runs offline mode now

Horizon has a newer version v.2.8.0.1 and you can download it below.
Download Horizon v2.8.0.1

no still running offline mode but it works on my m8s PC in Canada

Check if your Windows is up to date.

Steps to check if your Windows is up to date.

  1. Click start on your computer
  2. Search for “Windows Update”
  3. Click on the icon that should look like this: [details=Open Me][/details]
  4. Then click this option on the left side: [details=Open Me][/details]
  5. If you do need to update check this check mark: [details=Open Me][/details] This will select all the updates that you need to update
  6. After you select that press “Ok” in the bottom right hand corner.
  7. Now just install the updates: [details=Open Me][/details]

If this does not work, I will Teamview with you to fix your problem hands on.

Here is a little about the program:

Teamviewer is a program that let’s me take control of your computer to help you with your problem. The program is 100% safe you can stop me from controlling your computer at anytime.

Download Teamviewer

nope my windos has no updates

Do you wanna teamview and I can see if I can fix the problem hands on?

it still showing offline mode plz help

There is a newer version of Horizon that just came out today!

Download it from this link: https://www.horizonmb.com/client/v2/Horizon.Setup.v2.8.1.1.exe

thanks

Hi Guys.

Don’t work to me this version.
Already turn of my anti virus and firewall. Also i run as Admin and still offline mode.

And always appear a message to run as Admin. I’m doing it yet, and still appear the same message.

Any help? Thanks

Try this:

Look for the setup wherever you saved it and you’re going to want to right click on it then select properties.

After you’ve done that look around for a button saying “Unblock”. Press this then press “Okay” or “Apply”.

Make sure you’ve uninstalled Horizon then click on the setup and it should install fine.

Still not working fine.
I don’t know what i’m doing wrong :confused: