App Horizon

Horizon Support | Ultimate Help Thread


#1001

Open task manager and see if there is a process for Horizon. Your AV may be blocking it from opening past the splash screen.


#1002

Maybe it just takes a while to load…


#1003

I have installed the latest Horizon and this is what shows up
I have net framework 3.5

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: horizon.exe
Problem Signature 02: 2.8.4.0
Problem Signature 03: 546c0336
Problem Signature 04: Horizon
Problem Signature 05: 2.8.4.0
Problem Signature 06: 546c0336
Problem Signature 07: 212d
Problem Signature 08: 0
Problem Signature 09: System.TypeInitialization
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 1033

Read our privacy statement:
http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409


#1004

Be sure you are up to date with .net framework updates in Windows Update.


#1005

I listed net 3.5 because it says I need it
My net framework is fully up to date though and Horizon use to work now it doesn’t

update//I have unistalled than reinstall ALL of my net framework and horizon is still not working


#1006

horizon has stopped working is the error I have no anti virus except fire wall and its really annoying horizon is the only software that realy works so please help


#1007

Do you have .Net Framework 3.5 installed?

You should try uninstalling Horizon, and download the latest version Here, and reinstall and see if it helps.


#1008

yes have did both still nothing


#1009

If you want, Shadow, I can help you through Teamviewer. Basically (if you don’t know what Teamviewer is) I will control your computer with permission and I will help fix the problem hands on. You have control over me when I do control your computer, so it is not like I can really do anything to harm your computer at all. You can download Teamviewer from the link I provided below, and all you have to do after that is private message me your ID and Password!

Download Teamviewer: http://download.teamviewer.com/download/TeamViewer_Setup_en-icy.exe


#1010

i have a problem running horizon . after seeing the horizon logo for 2-3 sec it disappears without any error . a process is created on task manager but it shuts down any solutions ?


#1011

Do you know if you have .Net Framework 3.5 installed on your PC? If you don’t, download and install it it.
Download link: http://www.microsoft.com/en-us/download/details.aspx?id=21

If that doesn’t help post back and we’ll try some other possible fixes. Good luck.


#1012

sorry i forgot to mention that a couple of days ago everything was fine cuz i modded a save game and installed a couple of demos on my usb tried to do the same today but no luck :anguished: if it helps i m using windows 7 ultimate 64bit

P.S I have already installed net framework 3.5


#1013

UPDATE : I tried an older version 2.5.4.0 and it works :smile: i m going to test more versions out to see if i have only the problem with the 2.8.4.0 release


#1014

Try installing the latest version from this link: https://www.horizonmb.com/client/v2/latest.php


#1015

Hello Everyone,

I need help in horizonmb. When ever I use the Saints Row Iv save editor it give me the following error. " the given key is not present in the dictionary." thanks for helping me.


#1016

I had this version but i uninstalled it due to the problem i had , the ones i refered to my first post . Any other suggestions ?


#1017

You may need to delete the Daring_Development_Inc folder from your app data. Copy and paste this, %localappdata% into windows search bar and search it, open the local folder and find the folder mentioned above and delete it. Now make sure that you’ve uninstalled Horizon if you still have an older version installed and delete any installers that you may have downloaded to your computer. Now try downloading and installing from the link I gave you above.


#1018

after downloading it says file is corrupted and i have downloaded it several times but it didn’t work i think it is server problem


#1019

Try downloading from here: https://www.horizonmb.com/client/v2/latest.php
It should download, and install just fine.


#1020

Hello Guys When i inject the game demos or dlc files with horizon then i connect my usb to xbox the dlc files and games shown as Corrupted
why this happens and i can’t use dlc and games Please Help :cry:
And : My console is not Jtag or RGH