App Horizon

Horizon Support | Ultimate Help Thread


#1041

Sykotik I am also having the same issue of Horizon not starting up and I saw your post about the CPU redlining and killing the application cause it so I tried it out. It goes up usually around 50% or so. I tried it about 5 different times and it did once go up to around 85%. Would this be enough to not allow Horizon to start up? I have an Intel Core 2 Duo 2.2 GHz processor, would this be strong enough to launch it? Any information is greatly appreciated. Thank you


#1042

A Dual Core running at 2.0 GHz should be able to launch the program with no problem I think.


#1043

Ok then maybe we can figure out why I can’t get it to start. I have downloaded the latest version and I have the latest version of the .net framework and I even went as far as uninstalling my Symantec antivirus. I tried installing .net 3.5 even though I have a newer version and nothing works. I am running windows 7. Every time I try to open it, it acts like it wants to open with the spinning wait symbole next to my cursor and after about 10 seconds it goes away and I don’t even get an error message.


#1044

What is the message?


#1045

That’s the thing there is NO message of any sort it just won’t load.


#1046

Help !!! How do i run Horizon as administrator !!!


#1047

Right click on the Horizon shortcut icon and select Run as Administrator.


#1048

How can i extract cached profiles ?


#1049

Help. everytime i download this it doesnt finish the installation. what do i do


#1050

Try right clicking on the setup installer, click on properties, and click the Unblock button near the bottom, click apply, then ok. Now try installing. If it still gives you issues try re-downloading and installing Horizon from this link: https://www.horizonmb.com/client/v2/latest.php


#1051

Used Diamond to add the Unicorns to my garage in Forza 4. Didn’t work as planned and it looked like I lost all my progress like cars, tunes, cash etc. Played around with the program and recovered my info but now other problems have occured. All my cars are blacked out in the garage…can see them fine on the track. Can’t change my controller to layout 9 either, it reverts back to layout 1 each time. 3rd problem is I now have an account on my HD and one on the USB with all my history returned. Should I just delete the HD account even tho the same GT? How can I fix the black out condition. Thanks.


#1052

Got this error code:

An error has occured while writing back to the loaded Package!
If you see a developer the following message will help him resolve the issue.

STFS. Found an invalid hash entry while allocating. [Index:34, Level:1


#1053

Help PLEASE CANNOT USE!!!
Hi, I used horizon a few months ago and it worked perfectly fine. I recently started playing my xbox 360 again and I tried to use it again. I did everything I did last time: Move game save into formatted USB, plug it into computer and open horizon. When I put my USB into the computer though it shows up as removable disk and when I click on it and it opens up on file explorer the disk is completely empty. I tried formatting it to pc and back to xbox. I did it with three other USB’s and they all do the same thing. I tried it with multiple games and even with all the game files there the usb is still empty on my computer. It’s only empty on the computer and not on the xbox, when I make new files on my computer they don’t show on the xbox either. Someone PLEASE help i really wanna use horizon and went through a lot of trouble to try to do this. Any help is appreciated and again PLEASE help. Thx for your time and please reply soon


#1054

I can download it but it wont launch/load


#1055

i have diamond but says to update


#1056

Uninstall Horizon, and then reinstall after downloading the latest version from the link below.

https://www.horizonmb.com/client/v2/latest.php


#1057

I have a really important question does diamond auto renew every month (charge and take monthly) because if so I don’t think I want to go diamond ever


#1058

If you only want to purchase 1 month you simply cancel your subscription after making the initial payment.

Go here to cancel: https://www.horizonmb.com/payments.php


#1059

I still cant get Horizon to connect to the server. Ive tried turning off the fire wall & adding it as an acceptation. Ive turned off my AVG Anti-virus. Nothing seems to work. I’ve completely uninstalled it, and reinstalled it several times. Im using the most up to date horizon (2.8.5.0) I’ve been using horizon for over 2 years now on this PC with no issues, but now nothing will let me connect with it. If anyone knows what could be wrong, your help is appreciated.


#1060

Uninstall Horizon again, and then reinstall after downloading the latest version from this link: https://www.horizonmb.com/client/v2/latest.php