App Horizon

Horizon Support | Ultimate Help Thread


#1081

Good to know thanks


#1082

Anyone know how to convert an XBOX 360 ISO into a playable game on Horizon? All I have is a 64 GB flash drive.


#1083

You will need a modified console to do that.


#1084

everytime i mod forza horizon to or attempt it when i click save it save my usb is being used by another process, i can also view my xbox file from the usb itself but i cant open them please i need help i would appreciate it if you could either respond here or respond to my skype: unversedbog2540 (preferred)


#1085

right click on your horizon link make sure it is a link on the desktop not in your task bar>click properties>click the compatibility tab>make sure run as administrater is checked, also check run this progrm in compatibility mode for: then select the version of computer that you are running for example: im running windows 7 so i would click windows 7 (SP1)


#1086

Type of Problem : Not opening up it keeps saying “Stop Working”

  • OS : Windows 8.1

#1087

Will there ever be a Mac version of HorizonMB?


#1088

There are no plans to make a version that will work with OSX.


#1089

Nobody helped me on this problem and i paid $4.99 for 1 month so i hope this doesn’t take long :anguished:


#1090

Stop spamming every thread you can find. Have you disable your antivirus and firewall? Have you experienced similar issues with other programs? Also, you should have made sure you could run horizon “online” before purchasing diamond.


#1091

First of all i’m not spamming on every thread i can find second i had approval from Cheater912 that i look for suggestion on about fixing my problems so go mind your own third i’m very concern about my membership as a diamond member because i feel like i wasted my money on this and Horizon isn’t working for me alright so worry about your self and thx for telling what i can do to fix my problem.


#1092

Well, you make it really hard helping you.


#1093

Well thats the thing nobody fixed my problem i tried everything and nothing works i really appreciate everybody who tried to help me.


#1094

I’m sorry I couldn’t get it up and running for you, I suggested every last possible solution I could think of. If I come up with any more ideas I will surely let you know. Again, I’m sorry. I did try.


#1095

Anyone know what this means and how can I fix it? I recieved this error while trying to add all Unicorn cars into my Forza 4 profile. I walked through the steps, step by step, and no matter what when I try to save I keep getting the same error code :interrobang:
“String was not recognized as a valid Boolean”

Edit: This might not be the right forum section but I don’t know where to go to get help.


#1096

a question, what could cause this issue with my Horizon?


#1097

Hello all,

I have a Dell Inspiron E1405 pretty old Laptop. I was having absolutely no problems running Horizon at all the last couple days. However, My laptop started to get super slow so I reformatted and downloaded Horizon again now when I double click the installation file it does nothing.

I have noticed others with the same issues. Has there been a solution for this yet? I have .NET framework 3.5 installed then got the .NET 4.0 Web installer and still nothing is happening when I try to run the install file. Also I have no virus software at all on pc.

Any other suggestions would be helpful.


#1098

Ok, so i found what seemed to be the issue. I right clicked and chose properties and on the bottom it said this file came from another computer and has been blocked. I clicked unblock and then ran using administrator privledges and it seems to be running fine now. I’ll keep whoever needs to know posted on whether or not this actually 100% worked.

Worked 100% for me


#1099

Hi, I really have problems with my horizon. ive seen many people have this problem, i start horizon and the logo shows up. then it goes away. i tried every method. i have no virus protector, fire wall allows it, i think i got the new .net sometimes horizon will open. Its really annoying and i really want to mod some games, Thanks :smile:


#1100

Try Uninstalling and installing from this link:https://www.horizonmb.com/client/v2/latest.php

Make sure you have .NET framework 3.5 & 4.

If none of that helps, try running as admin.