Hotkeys are resetting on restart. Is that normal or not?

Dear developers and other users,

I just noticed that on every restart of Infinity I have to redo the hotkeys for the games. Lets say I change the one day a hotkey to go from F1 to F12. When I restart Infinity it is back to F1 again. Is this normal behaviour?

Thanks for this super program!

1 Like

@crabuslifr This shouldnā€™t happen. Do the hotkeys save if you go back to the homescreen before closing Infinity?

1 Like

Agree with ZACH.

I just tested this on my Infinity version, for ā€˜Homefront the Revolutionā€™, and the hotkeys remain saved as before.

Are you running Infinity as an ADMIN, and by any chance the shortcut of the Infinity app, or the main exe file marked as Read-only, or not (under file properties)?

Launch INFINITY from the desktopā€™s shortcut, and not the main Infinity application file, where the software is installed, under 2 different FOLDER Versionsā€¦

Check whether the shortcut file is for the latest build/version of INFINITY ?


Edit: By any chance did you hit the DEL/delete button on your keyboard, because doing this will restore the default hotkey values.

1 Like

Yes the hotkeys save when I go to Home and then back to the game. More details follow in reply to Nick_666 post.

1 Like

I run Infinity from the shortcut but I no longer have it on desktop but added it to the start menu but they are basically the same.

I have the shortcut setup to always run as administrator and the main program executable is also setup like that. Both files are not set as read only.

I do not press delete. So it only happens when I close and restart. But I just saw a new Infinity folder on the system.

Inside app-2.1.3 the .exe is not read only and run as ad.
Inside app-2.2.0 the .exe is not read only but does not run as ad. (now it does off course :slight_smile: after seeing it.)
The shortcut was linked to 220.

Trying if it works now. (via shortcut)

It just gave me the 1dec update message and it works. It remembered it. Very nice.

I should have asked this a few days ago when I encountered it for the first time now I look like a fool :wink:

Thanks Nick_666 and Zach for answering. Will do my best to return the favor by helping as much others as I can.

2 Likes

Thanks for the ā€œquickā€ update. So, it is working now, the Hotkeys are saving properly ? Oh, nvm, just saw your edited part of the post.

1 Like

Yes it is working. Sorry for all the edits. Had no idea you guys where so super quick. Thank you very much!

2 Likes

The ā€œapp-2.2.0ā€ folder should contain the latest installed files related to Infinity, apart from the old version.